summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 19:11:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 19:19:04 +0100
commit552f3393e6cd49c35a779a2300f771fe712a7584 (patch)
tree81fe292c4a4020c77a700d4730b818bbae5bcc5b /dev-python/rply
parentdev-python/hvac: Enable py3.11 (diff)
downloadgentoo-552f3393e6cd49c35a779a2300f771fe712a7584.tar.gz
gentoo-552f3393e6cd49c35a779a2300f771fe712a7584.tar.bz2
gentoo-552f3393e6cd49c35a779a2300f771fe712a7584.zip
dev-python/rply: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rply')
-rw-r--r--dev-python/rply/Manifest1
-rw-r--r--dev-python/rply/rply-0.7.8-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/rply/Manifest b/dev-python/rply/Manifest
index df06d0382e06..a94ce7c015ed 100644
--- a/dev-python/rply/Manifest
+++ b/dev-python/rply/Manifest
@@ -1 +1,2 @@
+DIST rply-0.7.8.gh.tar.gz 26697 BLAKE2B 95c4be3bbbd7aea7f278dbe0c37fd43d012df768169d0363d1a938f762c2f9ad69d596cbbaaafee3c93f3d615ea5cd1509e9b642188320f8acd09c12d6b7c780 SHA512 b43e6425f046561cfca616801d37d7151f015aeb2ea2365abc00f97fd6b41f1a01a17e330aed5a81537065e4b29d49cd0824b5a5cb8b2d11da2ff1f8de952fce
DIST rply-0.7.8.tar.gz 26697 BLAKE2B 95c4be3bbbd7aea7f278dbe0c37fd43d012df768169d0363d1a938f762c2f9ad69d596cbbaaafee3c93f3d615ea5cd1509e9b642188320f8acd09c12d6b7c780 SHA512 b43e6425f046561cfca616801d37d7151f015aeb2ea2365abc00f97fd6b41f1a01a17e330aed5a81537065e4b29d49cd0824b5a5cb8b2d11da2ff1f8de952fce
diff --git a/dev-python/rply/rply-0.7.8-r1.ebuild b/dev-python/rply/rply-0.7.8-r1.ebuild
new file mode 100644
index 000000000000..8564db9983de
--- /dev/null
+++ b/dev-python/rply/rply-0.7.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python parser generator that also works with RPython"
+HOMEPAGE="
+ https://github.com/alex/rply/
+ https://pypi.org/project/rply/
+"
+SRC_URI="
+ https://github.com/alex/rply/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs