summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-04-06 20:56:25 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-04-06 20:56:25 +0700
commit3538826cfea7d42cf7523ceeb920cb6a0119b984 (patch)
tree75e0827b08837616922f55462c5327dd8c6e0595 /dev-python/rpyc
parentmedia-gfx/asymptote: bump to 2.80 (diff)
downloadgentoo-3538826cfea7d42cf7523ceeb920cb6a0119b984.tar.gz
gentoo-3538826cfea7d42cf7523ceeb920cb6a0119b984.tar.bz2
gentoo-3538826cfea7d42cf7523ceeb920cb6a0119b984.zip
dev-python/rpyc: bump to 5.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest1
-rw-r--r--dev-python/rpyc/rpyc-5.1.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 5f6d96f50968..53b06ac7aae5 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1 +1,2 @@
DIST rpyc-5.0.1.tar.gz 1258657 BLAKE2B 84d0bee67004928c26a1765a26267e3e8eb5dc09a8fd53c1d75ca691cf313a7563398626b7e89a8893415294721623206204784da01444708edb56aec8101719 SHA512 57b0d6b2dba33c7f6c9d204b4deae8ab08ed56e5799aa2c7ae4bcb8ab98486055090e3079d8b0d615fcd517111a6e02893dff85607aaca5497ae76429abe3148
+DIST rpyc-5.1.0.tar.gz 1260651 BLAKE2B 4be17e5de4b0475cd63b99bf20e55e3221149f974b9efec638e0387d71815a5a2e4ea782578152690e019e7b8a4ece17405eed6626578a9c9e379d0f4b589008 SHA512 e9783392f423abca6b488dff5be36dae066980004bd221ca5a1c451f0f9dc7e1daf749650106802f9159de619a8d5e2cd6dc90e9a5f49d16f01bbedd59b504cf
diff --git a/dev-python/rpyc/rpyc-5.1.0.ebuild b/dev-python/rpyc/rpyc-5.1.0.ebuild
new file mode 100644
index 000000000000..9e44ad9daed5
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://github.com/tomerfiliba-org/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ # This test fails with NO_CIPHERS_AVAILABLE
+ rm tests/test_ssl.py || die "rm test_ssl.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do ${PYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}