summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rtgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rtgraph')
-rw-r--r--dev-python/rtgraph/Manifest1
-rw-r--r--dev-python/rtgraph/metadata.xml5
-rw-r--r--dev-python/rtgraph/rtgraph-0.70-r1.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/rtgraph/Manifest b/dev-python/rtgraph/Manifest
new file mode 100644
index 000000000000..90c5c58331b3
--- /dev/null
+++ b/dev-python/rtgraph/Manifest
@@ -0,0 +1 @@
+DIST rtgraph-0.70.tar.gz 16141 SHA256 e8030cfb63dcd13aa4eca08ea3c5b90f97678fcd5a3be1fecd65e124d93b397a SHA512 73d226ba09a658f6957fa82e4956de967ef7b02ca08ac1e33a16c1c0ffe1426afef35e7c720342524c6389e42d994db9ff3404d413ddec5168980e2e1982ea34 WHIRLPOOL 02bc67d436202be8e772385ddf2146f62c63f600db7186b825c111d2b46feb0ed08f7536653b45d175fbacb8bc59bf668c43d72bbddc4f185ff4ce7db0229a7f
diff --git a/dev-python/rtgraph/metadata.xml b/dev-python/rtgraph/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/rtgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/rtgraph/rtgraph-0.70-r1.ebuild b/dev-python/rtgraph/rtgraph-0.70-r1.ebuild
new file mode 100644
index 000000000000..7f367bdfd7ff
--- /dev/null
+++ b/dev-python/rtgraph/rtgraph-0.70-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Widgets for graphing data in real-time using PyGTK, and UI components for controlling the graphs"
+HOMEPAGE="http://navi.cx/svn/misc/trunk/rtgraph/web/index.html"
+SRC_URI="http://navi.picogui.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv ./{cpu_meter.py,graph_ui.py,isometric_graph.py,line_graph.py,polar_graph.py,tweak_graph.py} examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}