summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-19 20:44:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-19 20:50:25 +0100
commitd239fd6dcd56674bf92e2922e66474298b45a937 (patch)
tree23d5300b42aad7e6539f5a69f8e4af013f559a7b /dev-python/scandir
parentdev-python/python-zipstream: Port up to py3.9 (diff)
downloadgentoo-d239fd6dcd56674bf92e2922e66474298b45a937.tar.gz
gentoo-d239fd6dcd56674bf92e2922e66474298b45a937.tar.bz2
gentoo-d239fd6dcd56674bf92e2922e66474298b45a937.zip
dev-python/scandir: Port up to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scandir')
-rw-r--r--dev-python/scandir/scandir-1.10.0-r2.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/scandir/scandir-1.10.0-r2.ebuild b/dev-python/scandir/scandir-1.10.0-r2.ebuild
index 84c1093fe800..d7671f8bd5fe 100644
--- a/dev-python/scandir/scandir-1.10.0-r2.ebuild
+++ b/dev-python/scandir/scandir-1.10.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,11 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" test/run_tests.py -v || die "tests failed under ${EPYTHON}"
}