summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-27 11:50:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-27 11:53:14 +0200
commit791e15d6eeb75b1911e04894e5d75c187d0711a7 (patch)
tree823209564210d15f6fc7e2fb35e3c33f05f5ea48 /dev-python/scikit-learn
parentdev-python/xkbcommon: Remove old (diff)
downloadgentoo-791e15d6eeb75b1911e04894e5d75c187d0711a7.tar.gz
gentoo-791e15d6eeb75b1911e04894e5d75c187d0711a7.tar.bz2
gentoo-791e15d6eeb75b1911e04894e5d75c187d0711a7.zip
dev-python/scikit-learn: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-learn')
-rw-r--r--dev-python/scikit-learn/Manifest1
-rw-r--r--dev-python/scikit-learn/scikit-learn-1.5.0.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/scikit-learn/Manifest b/dev-python/scikit-learn/Manifest
index 720d475019bc..c5d0c26e1a8b 100644
--- a/dev-python/scikit-learn/Manifest
+++ b/dev-python/scikit-learn/Manifest
@@ -1,2 +1 @@
-DIST scikit-learn-1.5.0.gh.tar.gz 7806059 BLAKE2B d58a92fa230ee3f249cd9d9cf2cfd9406e12b0aaed6f3d3360fc5f914b7d690709786477474b95d90711f61b44d5490b01bcb57e36a320235591d3b2520dd9c0 SHA512 dfa6364770a982642c94e70a6ada8d60d3bba5e0a6e1d4acb622c102f176b39ba1c8b5ec8df6a12142afa258974cd606f0bdda4461dc23b7518bfaf71a7319cc
DIST scikit-learn-1.5.1.gh.tar.gz 6944196 BLAKE2B 65ed2016e1caf12e9a347e133b6b3be29b234de7ee8e374859a7235da3ede67a1b4c37a253b62ceb85a1ae3a1e6bc5afea2a0f07f4a7c81f59965614bde52b8c SHA512 f04c988490436d46d8210e68e41969af689810eff3e57098694768d3ccb7c4b919aecb13f36af1534745e56785fbf55c3dc3614497765d5b2f7c5e7e8dfbae05
diff --git a/dev-python/scikit-learn/scikit-learn-1.5.0.ebuild b/dev-python/scikit-learn/scikit-learn-1.5.0.ebuild
deleted file mode 100644
index bfe7835f2238..000000000000
--- a/dev-python/scikit-learn/scikit-learn-1.5.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="
- https://scikit-learn.org/stable/
- https://github.com/scikit-learn/scikit-learn/
- https://pypi.org/project/scikit-learn/
-"
-SRC_URI="
- https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
-IUSE="examples"
-
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
- >=dev-python/numpy-1.19.5:=[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/joblib-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/threadpoolctl-3.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pythran-0.14.0[${PYTHON_USEDEP}]
- >=dev-python/cython-3.0.10[${PYTHON_USEDEP}]
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-# For some reason this wants to use urllib to fetch things from the internet
-# distutils_enable_sphinx doc \
-# dev-python/matplotlib \
-# dev-python/memory-profiler \
-# dev-python/numpydoc \
-# dev-python/pandas \
-# dev-python/pillow \
-# dev-python/seaborn \
-# dev-python/sphinx-gallery \
-# dev-python/sphinx-prompt \
-# dev-python/scikit-image
-
-python_test() {
- rm -rf sklearn || die
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest --pyargs sklearn
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete || die
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}