summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/shm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/shm')
-rw-r--r--dev-python/shm/Manifest1
-rw-r--r--dev-python/shm/files/shm-1.2.2-compiler.patch11
-rw-r--r--dev-python/shm/metadata.xml5
-rw-r--r--dev-python/shm/shm-1.2.2-r1.ebuild28
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/shm/Manifest b/dev-python/shm/Manifest
new file mode 100644
index 000000000000..577a6b995df4
--- /dev/null
+++ b/dev-python/shm/Manifest
@@ -0,0 +1 @@
+DIST shm-1.2.2.tar.gz 25258 SHA256 5d733f61b26c2b71e46add5db6a74b50cb88e7339a30d91931bd10b85ddc8189 SHA512 d3da728d7c314b208b235490ae45b9f9ed4e7ac5c233867844b842ee511e50b684c52e75cc9258d0f65aa93ff2b10bca6a4bebfa6aef9b43d07ab284c0cab2a6 WHIRLPOOL 77c4ceb2e666aa3fa412de80dd25712d81d48cc859e1a2d993a08f82644dbbcee439396dc7a06a53dd408b3d38ee053399e23d8c5e3e82e437bfacd6300bbc1b
diff --git a/dev-python/shm/files/shm-1.2.2-compiler.patch b/dev-python/shm/files/shm-1.2.2-compiler.patch
new file mode 100644
index 000000000000..e9e1bd22a3a1
--- /dev/null
+++ b/dev-python/shm/files/shm-1.2.2-compiler.patch
@@ -0,0 +1,11 @@
+--- setup.py 2010-06-26 03:29:30.000000000 +0200
++++ setup.py 2010-06-26 03:30:10.000000000 +0200
+@@ -84,7 +84,7 @@
+ filename = "%d.c" % i
+ file(path + filename, "w").write(src % ('_' * i))
+
+- cmd = ["cc", "-c", "-o", "/dev/null", "%s" % path + filename]
++ cmd = [os.environ.get("CC", "cc"), "-c", "-o", "/dev/null", "%s" % path + filename]
+
+ po = popen2.Popen4(cmd)
+ if not po.wait(): underscores[i] = True
diff --git a/dev-python/shm/metadata.xml b/dev-python/shm/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/shm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/shm/shm-1.2.2-r1.ebuild b/dev-python/shm/shm-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..135c96317432
--- /dev/null
+++ b/dev-python/shm/shm-1.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to access System V shared memory and semaphores"
+HOMEPAGE="http://nikitathespider.com/python/shm/"
+SRC_URI="http://nikitathespider.com/python/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-compiler.patch )
+
+python_install_all() {
+ dohtml ReadMe.html
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}