summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 09:30:20 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 09:38:39 +0100
commit6f1b91bd4d4299a6121e1d0b9f018097926cc822 (patch)
tree05e959e5696d58741d85f157f4771a0de71d3eac /dev-python/sigstore
parentdev-python/rfc3161-client: New NIH dep for sigstore, v0.0.4 (diff)
downloadgentoo-6f1b91bd4d4299a6121e1d0b9f018097926cc822.tar.gz
gentoo-6f1b91bd4d4299a6121e1d0b9f018097926cc822.tar.bz2
gentoo-6f1b91bd4d4299a6121e1d0b9f018097926cc822.zip
dev-python/sigstore: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sigstore')
-rw-r--r--dev-python/sigstore/Manifest1
-rw-r--r--dev-python/sigstore/sigstore-3.6.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/sigstore/Manifest b/dev-python/sigstore/Manifest
index f166a02a3213..69246c63df9c 100644
--- a/dev-python/sigstore/Manifest
+++ b/dev-python/sigstore/Manifest
@@ -1 +1,2 @@
DIST sigstore-python-3.5.3.gh.tar.gz 201724 BLAKE2B 7b73ecd51944bc461213044931b7cfd3986442e9dc380cad5093c5f8dba82142c4a556bf9e43d869373df3d4ec07d8f023dde907045b2a172cfa06fd874e5907 SHA512 53d9876470156f91eb21e4e32ef1f61101e4a4011b689ad0b808414e19296266f66fc2bde1d5ad8178c3bb71824e1b30213672d8f1a311fb80a9fb4623a8a1cc
+DIST sigstore-python-3.6.0.gh.tar.gz 235198 BLAKE2B f0b7acdc6cb3b903b7938c319d220479e4e0532fbb625f4e6543b76e12ca32e6e551eb51c9d383fcea996ff410599a36d463fb53b88c8b44bc08d5a15a82b03a SHA512 cde7ae0df8f727659ed4c803143c1b49bb1045c9e96b137f095896b66a8b04269201f93e481965b6eca72b050468ba0c7a56ceb51f44523de90d114b23deff89
diff --git a/dev-python/sigstore/sigstore-3.6.0.ebuild b/dev-python/sigstore/sigstore-3.6.0.ebuild
new file mode 100644
index 000000000000..3604b7def641
--- /dev/null
+++ b/dev-python/sigstore/sigstore-3.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=sigstore-python-${PV}
+DESCRIPTION="A tool for signing Python package distributions"
+HOMEPAGE="
+ https://github.com/sigstore/sigstore-python/
+ https://pypi.org/project/sigstore/
+"
+# no tests in sdist, as of 3.3.0
+SRC_URI="
+ https://github.com/sigstore/sigstore-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/cryptography-44[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-42[${PYTHON_USEDEP}]
+ >=dev-python/id-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ~dev-python/rfc3161-client-0.0.4[${PYTHON_USEDEP}]
+ >=dev-python/rfc8785-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.0[${PYTHON_USEDEP}]
+ ~dev-python/sigstore-protobuf-specs-0.3.2[${PYTHON_USEDEP}]
+ ~dev-python/sigstore-rekor-types-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/tuf-5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-resources-5.7[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unpin deps
+ sed -i -e 's:~=:>=:' pyproject.toml || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest test/unit --skip-online
+}