summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-30 14:07:53 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-30 14:40:53 -0500
commit26015185884dbf8a89578be9ea30cd01772fdb7a (patch)
tree8e555e73813ff3ecc737d0bb4a4ab945d8501b82 /dev-python/sip
parentdev-libs/ncnn: drop 20230816 (diff)
downloadgentoo-26015185884dbf8a89578be9ea30cd01772fdb7a.tar.gz
gentoo-26015185884dbf8a89578be9ea30cd01772fdb7a.tar.bz2
gentoo-26015185884dbf8a89578be9ea30cd01772fdb7a.zip
dev-python/sip: add 6.8.0
Closes: https://bugs.gentoo.org/916261 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/files/sip-6.8.0-typo-fix.patch11
-rw-r--r--dev-python/sip/sip-6.8.0.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 622f9a4d2c06..3d385922cbe7 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,2 +1,3 @@
DIST sip-6.7.12.tar.gz 1169656 BLAKE2B 07ae682e783da5bc6fc3109c62c7bff245faab795cc28f135758b1211fae1dfae79668e7e7c0de8b3bae5c8b10534d153cdd47969b34149c8f5598867d19f17c SHA512 885c32a051e882b82b59bf1365050933f8fc1c619b19f4bc03235edc5741a5e14aae8edf90479ad0283f74ba5c5233a2589c151ec865b130199a6db9800a2294
DIST sip-6.8.0.dev2310230931.tar.gz 1126109 BLAKE2B 53efdb9722888645b9772c6080f34459b89c745a02cfb9842f7924870afa81d4ba06ec6ac730ee1d254f5252c1c495a4b4dfd51157d759d7334d2980145214f8 SHA512 8bac33c9ae87dc11669837e2b07d5016a7e16e743439dbf763c13a118476431058d2a6c4b0c29e4ce7a7f5f86602bb1c9f27ccf0d3f6c1a298b06256f820ceaa
+DIST sip-6.8.0.tar.gz 985563 BLAKE2B 676636882a5bb39b226e7b25ae60cec43bf8ccfe9af085e14d9ff627af5ee579cc3ba01dbc5c2e75490575888fabdbd469895dbd964ea741d9e86748bebc1097 SHA512 09e25e3937339b6dbaa0b693bf0b99e5c225751ca79e0a307387c331f2b84e4e5a276897b471a123d24715e5d9cb85e84d244cf07960ff6f53f75859bbb2f901
diff --git a/dev-python/sip/files/sip-6.8.0-typo-fix.patch b/dev-python/sip/files/sip-6.8.0-typo-fix.patch
new file mode 100644
index 000000000000..637d416d403e
--- /dev/null
+++ b/dev-python/sip/files/sip-6.8.0-typo-fix.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/916261
+https://www.riverbankcomputing.com/pipermail/pyqt/2023-November/045607.html
+--- a/sipbuild/generator/outputs/code.py
++++ b/sipbuild/generator/outputs/code.py
+@@ -8409,5 +8409,5 @@
+ is_first = True
+
+- if klass.docstring is None or klass.docstring.signature is not SocstringSignature.DISCARDED:
++ if klass.docstring is None or klass.docstring.signature is not DocstringSignature.DISCARDED:
+ for ctor in klass.ctors:
+ if ctor.access_specifier is AccessSpecifier.PRIVATE:
diff --git a/dev-python/sip/sip-6.8.0.ebuild b/dev-python/sip/sip-6.8.0.ebuild
new file mode 100644
index 000000000000..67ecebb1da3e
--- /dev/null
+++ b/dev-python/sip/sip-6.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+PATCHES=(
+ "${FILESDIR}"/${P}-typo-fix.patch
+)