summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:56:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:56:29 +0200
commit61554cd3455071eed874eab26b6c8068abb4998b (patch)
tree2d274f0987507471f072bd0358d17c35b6c7b3e6 /dev-python/soupsieve/soupsieve-2.0.1.ebuild
parentdev-python/soupsieve: Bump to 1.9.6 (diff)
downloadgentoo-61554cd3455071eed874eab26b6c8068abb4998b.tar.gz
gentoo-61554cd3455071eed874eab26b6c8068abb4998b.tar.bz2
gentoo-61554cd3455071eed874eab26b6c8068abb4998b.zip
dev-python/soupsieve: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/soupsieve/soupsieve-2.0.1.ebuild')
-rw-r--r--dev-python/soupsieve/soupsieve-2.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/soupsieve/soupsieve-2.0.1.ebuild b/dev-python/soupsieve/soupsieve-2.0.1.ebuild
new file mode 100644
index 000000000000..bc7d0fd6f292
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="https://github.com/facelessuser/soupsieve
+ https://pypi.python.org/pypi/soupsieve"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT+=" !test? ( test )"
+
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest