summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-03 02:42:04 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-04 06:02:04 +0000
commit0ef27c60ebc1d8b3103e943efe35e4173584682b (patch)
treea170437899bda91928ef618963b6bcc57d5bf740 /dev-python/sphinx-gallery
parentdev-util/eric: version bump (diff)
downloadgentoo-0ef27c60ebc1d8b3103e943efe35e4173584682b.tar.gz
gentoo-0ef27c60ebc1d8b3103e943efe35e4173584682b.tar.bz2
gentoo-0ef27c60ebc1d8b3103e943efe35e4173584682b.zip
dev-python/sphinx-gallery: fix nose depedency
And add basic testing. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild (renamed from dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
index a1f4cb520d93..7f9ae300f5a9 100644
--- a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,6 +22,14 @@ RDEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
"
+# yes nose is somehow required besides testing
DEPEND="
+ dev-python/nose[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
"
+
+python_test() {
+ echo 'backend: agg' > matplotlibrc
+ VARTEXFONTS="${T}"/fonts MPLCONFIGDIR="${BUILD_DIR}" \
+ nosetests -v || die
+}