summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-14 06:18:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-14 06:18:51 +0100
commit15d76ea3e49bf90f74df649773167d6ba96c0583 (patch)
tree46950f6ffc575325144006f0641caef4350ada8a /dev-python/sphinx-rtd-theme
parentdev-python/sphinx_rtd_theme: Use pypi.eclass (diff)
downloadgentoo-15d76ea3e49bf90f74df649773167d6ba96c0583.tar.gz
gentoo-15d76ea3e49bf90f74df649773167d6ba96c0583.tar.bz2
gentoo-15d76ea3e49bf90f74df649773167d6ba96c0583.zip
Rename dev-python/{sphinx_rtd_theme → sphinx-rtd-theme}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-rtd-theme')
-rw-r--r--dev-python/sphinx-rtd-theme/Manifest2
-rw-r--r--dev-python/sphinx-rtd-theme/metadata.xml13
-rw-r--r--dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.1.1.ebuild42
-rw-r--r--dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild44
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/sphinx-rtd-theme/Manifest b/dev-python/sphinx-rtd-theme/Manifest
new file mode 100644
index 000000000000..eb9bcc6d300f
--- /dev/null
+++ b/dev-python/sphinx-rtd-theme/Manifest
@@ -0,0 +1,2 @@
+DIST sphinx_rtd_theme-1.1.1.tar.gz 2783043 BLAKE2B c132cc4bba5459ca29740222cc917aac0fa5afb26748b1bd3d457ed0a02e63cd973deecd9a3d509187f54ae85798cb63fdfaa293615eae278228753808fd8c50 SHA512 c3e6e3a9d25b9c48a9830e696ca5c8f0c185a0328c76032cbe6dcfb93cda7ad9a724ec4e0e2a99079db28f35aa61ef2f569b87ce98a01c47a9701a6070bc395e
+DIST sphinx_rtd_theme-1.2.0.tar.gz 2784826 BLAKE2B 62d0af56a29d66831447009991a5e0fb0a483ca91ac2ef7e7ce0b19510281308b49219efd0c6e1bd8fc95c2acae233133ce2f89b7507c2b20f0f322e59ab06e0 SHA512 dd407c648c5512a79e31a106825c6f9ec4696b14d950830ab36faf912ea804b48b3a5d09c6a144e9cead773e4c057cbc809d7582deea1b253ce71b756f7f6b10
diff --git a/dev-python/sphinx-rtd-theme/metadata.xml b/dev-python/sphinx-rtd-theme/metadata.xml
new file mode 100644
index 000000000000..9b67795adb8e
--- /dev/null
+++ b/dev-python/sphinx-rtd-theme/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">sphinx-rtd-theme</remote-id>
+ <remote-id type="github">readthedocs/sphinx_rtd_theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.1.1.ebuild b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.1.1.ebuild
new file mode 100644
index 000000000000..2893f979a846
--- /dev/null
+++ b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/sphinx_rtd_theme/
+ https://pypi.org/project/sphinx-rtd-theme/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+IUSE=""
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin docutils
+ sed -i -e '/docutils/s:<0.18::' setup.cfg || die
+ distutils-r1_src_prepare
+
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}
diff --git a/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild
new file mode 100644
index 000000000000..814a48f1af37
--- /dev/null
+++ b/dev-python/sphinx-rtd-theme/sphinx-rtd-theme-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/sphinx_rtd_theme/
+ https://pypi.org/project/sphinx-rtd-theme/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <dev-python/sphinx-7[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-jquery-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin docutils
+ sed -i -e '/docutils/s:<0[.]19::' setup.cfg || die
+ sed -i -e '/jquery/s:,!=3[.]0[.]0::' setup.cfg || die
+ distutils-r1_src_prepare
+
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}