summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-02 02:35:06 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:25 +0000
commitc0a4ccb703975d8b3b5c7b9655d214d4e80a1b70 (patch)
tree76ef998cbfb6215238d03895f0f5882720e3ac05 /dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
parentdev-python/sphinxcontrib-programoutput: version bump (diff)
downloadgentoo-c0a4ccb703975d8b3b5c7b9655d214d4e80a1b70.tar.gz
gentoo-c0a4ccb703975d8b3b5c7b9655d214d4e80a1b70.tar.bz2
gentoo-c0a4ccb703975d8b3b5c7b9655d214d4e80a1b70.zip
dev-python/sphinxcontrib-spelling: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
new file mode 100644
index 000000000000..4424910a7ac7
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+CDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}