summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-30 09:05:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-30 11:45:07 +0200
commitc16937f0ef8eac92e8fd7c977a41e7be83b3c7ce (patch)
tree53ec0c445da33aa26a677b8e92cc920d9e54cb64 /dev-python/sphinxcontrib-websupport
parentdev-python/pytz: Bump to 2020.1 (diff)
downloadgentoo-c16937f0ef8eac92e8fd7c977a41e7be83b3c7ce.tar.gz
gentoo-c16937f0ef8eac92e8fd7c977a41e7be83b3c7ce.tar.bz2
gentoo-c16937f0ef8eac92e8fd7c977a41e7be83b3c7ce.zip
dev-python/sphinxcontrib-websupport: Bump to 1.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest1
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index 6f0d5da0e7b0..3415d12695da 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-websupport-1.1.0.tar.gz 587947 BLAKE2B fafaa56071245c8934e27c6d2d7752745b2a8047c8a30d52e513fff7f952086a1b9082aa15e15ef232d69ef0c0d5d117f8a8c97fcdf9cd90c89d53238d7f322e SHA512 adbd7db06150a4424a881a22442c2535ed823c7adcc295ef9c3af5ae38d823349830a114e8a7af2138498d0e68b37189707c1bb5a28b45c76031bcf94210fb89
DIST sphinxcontrib-websupport-1.2.1.gh.tar.gz 599593 BLAKE2B b996db8c799399c8830cc984a7aedd5c4c259085d5eafbb020875e86a79366c154e7f2d8c02f82139e83135cb728e6b8c906d88c2d93dfc0346a9d82e81ba67f SHA512 b22cb7e2ef87da1a4be5da90011fd6aacbff440b9d2051fd9fbb4c9354be07e600af9e59d5843c5e9053bbb2f09a152d6ff6d695b6fa093b741379b3520055d4
+DIST sphinxcontrib-websupport-1.2.2.gh.tar.gz 599606 BLAKE2B d7e5754491d0f4e4b508bb5ed58f41d6f57c8785ce2d658cd4beb658b9a01a453bd791e73deab703ebf17d18ddf0a3adc7c72a49e80c33475daca41666da694d SHA512 39d7d688515440fcf7a0df9cff60402499956da4c4d5de4e7b38982ff23ed837e7851a3c747135b9298d0df59f3055a8f588be78f10d98110ab50b8ab434db34
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.2.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.2.ebuild
new file mode 100644
index 000000000000..a98a22eff6f7
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-websupport"
+# pypi tarball is missing templates
+SRC_URI="https://github.com/sphinx-doc/sphinxcontrib-websupport/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
+ >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # breaks tests
+ sed -i -e '/pkg_resources/d' \
+ sphinxcontrib/websupport/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}