summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-03 10:33:43 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-03 10:35:04 +0200
commit6950fbc97118d1249ca8c9a6d8d86690109948de (patch)
treec0d9ca6074be7449cde76d1f4c6ff6fd75f012d5 /dev-python/spyder-unittest
parentdev-python/spyder-unittest: add 0.6.0 (diff)
downloadgentoo-6950fbc97118d1249ca8c9a6d8d86690109948de.tar.gz
gentoo-6950fbc97118d1249ca8c9a6d8d86690109948de.tar.bz2
gentoo-6950fbc97118d1249ca8c9a6d8d86690109948de.zip
dev-python/spyder-unittest: drop 0.5.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/Manifest1
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/spyder-unittest/Manifest b/dev-python/spyder-unittest/Manifest
index 9bd499e8ac39..0734087a0fe5 100644
--- a/dev-python/spyder-unittest/Manifest
+++ b/dev-python/spyder-unittest/Manifest
@@ -1,2 +1 @@
-DIST spyder-unittest-0.5.1.gh.tar.gz 80022 BLAKE2B c904196f7b0288b4d4f105037cbf75fc7ef60669ba1a24687b4f6aa672b88b139b64282c2d12340c958a3ffb65b8cf01b61256f669e167a6c15eb9471430af2a SHA512 4bea5d88b6be80435e2fa6498803ceea275b72c47bd0a54bb3be962bfe00feed2073e4d4915ea1b4dd780cb1c104f6dcd2735ee000cdedb934ed9fac059d0ca5
DIST spyder-unittest-0.6.0.gh.tar.gz 105932 BLAKE2B b7a39e5756d27325bbe0dff32fb3922f667cdd1eb2c3a6d9e5eceb89abd921244fdf1685706bff181c75c59f86f92e405a1d08c5e86d7f15a27bfd46d32048ea SHA512 304843dcf6b51033a6acbc81a0ed274736d36967d95866075bb06a23487f29556256e39c213f685f5a6622743bba568814b5c099fa143e849fdb5608687f1c5c
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild
deleted file mode 100644
index 43ce967da1ec..000000000000
--- a/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 virtualx
-
-COMMIT="d210d9fe6c4efbb21d680a040cc4741d76a81f49"
-
-DESCRIPTION="Plugin for Spyder to run tests and view the results"
-HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-# AttributeError: 'NoneType' object has no attribute 'split'
-RESTRICT="test"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/spyder-5.3.1[${PYTHON_USEDEP}]
- <dev-python/spyder-6[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-
-python_test() {
- virtx epytest
-}