summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-02 05:52:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-11-02 06:44:24 +0100
commitab9edad4b3a4924f6544fb69096140f416d8e59c (patch)
treef14a7cb3a51d7764940cff1c3fedcd20e8af907a /dev-python/sqlglot
parentdev-python/wcwidth: Remove old (diff)
downloadgentoo-ab9edad4b3a4924f6544fb69096140f416d8e59c.tar.gz
gentoo-ab9edad4b3a4924f6544fb69096140f416d8e59c.tar.bz2
gentoo-ab9edad4b3a4924f6544fb69096140f416d8e59c.zip
dev-python/sqlglot: add 19.0.2
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/33639 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-19.0.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 3f32912a6df2..6b6b7af666c6 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1 +1,2 @@
DIST sqlglot-19.0.0.tar.gz 8955220 BLAKE2B 9f53b726efb379b72f93f55796ae110be2f0596c4e4156e4c67ba899b0138fd6abb28b0a800c6d79c58bba565cb551ad42c94c8fba26ffcea854ad94a35971f0 SHA512 ac679f5c2d911a46ca6c4183ae3542e7a436185f37af494c8a35b657e5fe552cfea2e7d6c142721bb2247f91d5ceda8f602cc54a80b19a3ed72a95d9a9ed4e82
+DIST sqlglot-19.0.2.tar.gz 8980868 BLAKE2B 07e6d0af365a45cdac27e7b976979bbd26b36931438928ca169fbfe18598a01b067a736cc0f2f97684c93e574d45f61d0c3f357c2c1321c6e344b7227817acce SHA512 3639e2e1c020c26893ae750bbf20669cf722e2e93e8438934db732c8e79791c61fa3363bf887455b04dee50ebe76fd8d689279fed22260a807a8b3b1f035c9c0
diff --git a/dev-python/sqlglot/sqlglot-19.0.2.ebuild b/dev-python/sqlglot/sqlglot-19.0.2.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-19.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}