summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-14 08:06:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-14 08:29:16 +0200
commitc1217cf583b4f34489a588a7a942d3f5df207407 (patch)
tree718b5dcd7dd165454801096842c23b77ce85fce7 /dev-python/sqlglot
parentdev-python/sqlglot: Remove old (diff)
downloadgentoo-c1217cf583b4f34489a588a7a942d3f5df207407.tar.gz
gentoo-c1217cf583b4f34489a588a7a942d3f5df207407.tar.bz2
gentoo-c1217cf583b4f34489a588a7a942d3f5df207407.zip
dev-python/sqlglot: Bump to 18.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-18.13.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 1229ef9ed572..04c348125b87 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1 +1,2 @@
DIST sqlglot-18.12.0.tar.gz 8854252 BLAKE2B 30bd8a7a8d4dd2337c61b4bddcce74a35a7594ed6ac16e0c68f3103c54c1eb9499246d2ec340ae3ebb137a09a2fb29c4a9e0a82eacef959c9cac1204fa68da0d SHA512 0ac80e9f51f68121f5cf7ac7db08832ac48e706dcdb966ab1c432d4d81dc808221e3b45fd6bf31f570ff7add1a49de2f82a8671b8c81d27efb402776c20d6fd3
+DIST sqlglot-18.13.0.tar.gz 8873766 BLAKE2B 4dfe6d3d6332bedf13229d2820a12ead44ffcaad0f3f68bb1578d62c325173fddd73f9033277cb0ed8cdfa8e919464ce0efa51ba7dc2a946e725c1698f2afdf8 SHA512 6ed3d4eca1496b800c677b45df5499f96266e09b3c0909b8af9c4512a1bab7b7cfabaf89dad6353af2f579211364597b1ffb0f55975ffcd8c3f520802621e9aa
diff --git a/dev-python/sqlglot/sqlglot-18.13.0.ebuild b/dev-python/sqlglot/sqlglot-18.13.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}