summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-23 08:49:34 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-23 11:29:00 +0200
commit8bdf6a69de03dbd3cb631661ffb770fd3519d608 (patch)
treee4d09dc542f6600a048ab7d123c9d04d573e67af /dev-python/tabulate
parentdev-python/tabulate: bump to python 3.10 (diff)
downloadgentoo-8bdf6a69de03dbd3cb631661ffb770fd3519d608.tar.gz
gentoo-8bdf6a69de03dbd3cb631661ffb770fd3519d608.tar.bz2
gentoo-8bdf6a69de03dbd3cb631661ffb770fd3519d608.zip
dev-python/tabulate: disable tests using deselect instead of patch
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch80
-rw-r--r--dev-python/tabulate/tabulate-0.8.9.ebuild18
2 files changed, 14 insertions, 84 deletions
diff --git a/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch b/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch
deleted file mode 100644
index b75df197f80e..000000000000
--- a/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff --git a/test/test_input.py b/test/test_input.py
-index 5443ab9..8a1d2e5 100644
---- a/test/test_input.py
-+++ b/test/test_input.py
-@@ -4,6 +4,7 @@
-
- from __future__ import print_function
- from __future__ import unicode_literals
-+import unittest
- from tabulate import tabulate
- from common import assert_equal, assert_in, assert_raises, SkipTest
-
-@@ -246,6 +247,7 @@ def test_numpy_record_array_headers():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas():
- "Input: a Pandas DataFrame."
- try:
-@@ -267,6 +269,7 @@ def test_pandas():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_firstrow():
- "Input: a Pandas DataFrame with the first row as headers."
- try:
-@@ -285,6 +288,7 @@ def test_pandas_firstrow():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_keys():
- "Input: a Pandas DataFrame with keys as headers."
- try:
-diff --git a/test/test_output.py b/test/test_output.py
-index 1eb67c1..2106c88 100644
---- a/test/test_output.py
-+++ b/test/test_output.py
-@@ -4,6 +4,7 @@
-
- from __future__ import print_function
- from __future__ import unicode_literals
-+import unittest
- import tabulate as tabulate_module
- from tabulate import tabulate, simple_separated_format
- from common import assert_equal, assert_raises, SkipTest
-@@ -1176,6 +1177,7 @@ def test_unaligned_separated():
- assert_equal(expected, result)
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_with_index():
- "Output: a pandas Dataframe with an index"
- try:
-@@ -1199,6 +1201,7 @@ def test_pandas_with_index():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_without_index():
- "Output: a pandas Dataframe without an index"
- try:
-@@ -1222,6 +1225,7 @@ def test_pandas_without_index():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_rst_with_index():
- "Output: a pandas Dataframe with an index in ReStructuredText format"
- try:
-@@ -1247,6 +1251,7 @@ def test_pandas_rst_with_index():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_rst_with_named_index():
- "Output: a pandas Dataframe with a named index in ReStructuredText format"
- try:
diff --git a/dev-python/tabulate/tabulate-0.8.9.ebuild b/dev-python/tabulate/tabulate-0.8.9.ebuild
index 7d9e13d8ec05..fd5ed0277274 100644
--- a/dev-python/tabulate/tabulate-0.8.9.ebuild
+++ b/dev-python/tabulate/tabulate-0.8.9.ebuild
@@ -25,8 +25,18 @@ BDEPEND="
)
"
-PATCHES=(
- "${FILESDIR}/tabulate-0.8.6-avoid-pandas-dep.patch"
-)
-
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # avoid pandas dependency
+ test/test_input.py::test_pandas
+ test/test_input.py::test_pandas_firstrow
+ test/test_input.py::test_pandas_keys
+ test/test_output.py::test_pandas_with_index
+ test/test_output.py::test_pandas_without_index
+ test/test_output.py::test_pandas_rst_with_index
+ test/test_output.py::test_pandas_rst_with_named_index
+ )
+ epytest ${deselect[@]/#/--deselect }
+}