summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-20 23:38:42 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-20 23:40:22 +0100
commit741695b8ccb5cbbc6ba518734d0a22b71e95de0d (patch)
treec2fbacc3fa198700e63cf37a5cc44c345729781d /dev-python/tempora
parentdev-python/tempora: bump to 2.1.1 (diff)
downloadgentoo-741695b8ccb5cbbc6ba518734d0a22b71e95de0d.tar.gz
gentoo-741695b8ccb5cbbc6ba518734d0a22b71e95de0d.tar.bz2
gentoo-741695b8ccb5cbbc6ba518734d0a22b71e95de0d.zip
dev-python/tempora: remove old
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-1.12.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 961caa7e5539..260eb499958a 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1,4 +1,3 @@
-DIST tempora-1.12.tar.gz 15208 BLAKE2B ced6e5d069780b516ff791ee598683f59d02588d45282f1b6b6c2b8b61d354bc399d10c961b5a112c7ef1185c3661cbe9b1b9c95ab28d42ed2429fa4f504917e SHA512 4acd38fb464e858db371fc4ac6d2082f4f0c676016cdb95d8415895b7d0bdd3c787c2678737e437d1f5861368dd54040ce289407cfeea3ca43b130c56da133b6
DIST tempora-1.14.1.tar.gz 19383 BLAKE2B f65896391e839c3da43bb42715459b9ab870a724722bfc83c129f18032e731d69b2d12635a519226ef4ce99e77a3418e7e1a05a116a80c222b4e8138f9966f9e SHA512 4ecd5430d4d90959b0985908a1e4f239a56ce0026cd315ef6b8c204b645caccb135db76bb2ca9cb95bc65bdf337b61e7c31514eb9c85036771469b6a058edfbb
DIST tempora-1.7.tar.gz 11645 BLAKE2B d354fb863a8d30bd9e603ad942d7c7f61a70c24e7f1fe94fffd59982431190e2807c2dc577ff83eb90ffc5fd2b2f8415965de1d77e4dca0dd02291733bfbb97c SHA512 2420e32a9b8c990609d8f09225004e0b1c445cad1fe3c3c74625cb8317b552469acf2d3b28aa56633a87260a93c77d73b02178cb662016c514bc740aa01399e5
DIST tempora-2.0.0.tar.gz 19828 BLAKE2B af06f7cfd6742c41fa08333da30bd2b6173affe4d368024122d0464856fa3e2264c85d34505cae023167b4266ed0e927a5a8d620101c02c352cf08b269c8c6b4 SHA512 9f488ecca0673a0071503475378bc8f5ddcfabb32fcc548392434df45767fbeb8b914117622ec6f9dc6a8de90e5bfe6e5571a9a18ddecf7c25e94fc1f7fff102
diff --git a/dev-python/tempora/tempora-1.12.ebuild b/dev-python/tempora/tempora-1.12.ebuild
deleted file mode 100644
index 9718791ac174..000000000000
--- a/dev-python/tempora/tempora-1.12.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_6 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="https://github.com/jaraco/tempora"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Override pytest options to skip flake8
- PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}