summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-14 16:34:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-14 16:55:16 +0200
commit103f409b1bc065f3beea6cc2d46214d83a8abde2 (patch)
treef3c95730ce65c5ef9cd3a492f2db13cafc97b5a7 /dev-python/tenacity
parentdev-python/peewee: Bump to 3.16.3 (diff)
downloadgentoo-103f409b1bc065f3beea6cc2d46214d83a8abde2.tar.gz
gentoo-103f409b1bc065f3beea6cc2d46214d83a8abde2.tar.bz2
gentoo-103f409b1bc065f3beea6cc2d46214d83a8abde2.zip
dev-python/tenacity: Bump to 8.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-8.2.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 66e9b25dd5b8..385bdc6502aa 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-8.2.2.tar.gz 40186 BLAKE2B af24fa209a0f9de0bb7ddd0d0979620fdb3a41967ea2d45c8864cc9feb3237d345b85015379228dd7714d7dd3f921e190bfdea3ba5c3fe627df804de6641894d SHA512 a1e2569dd5afdc982716f22ba7c67f7a43351e9f2dbefad30854d8655fa7600300c624b7353ea7d68aa462cbf2f33cf93e643e2868e8e197a61eb1ccf25c275e
+DIST tenacity-8.2.3.tar.gz 40651 BLAKE2B c79af0a6e0ee0af52fe47579b830ee911b10bd780467eaa22308443830a29cf76583455acbe53c92805abb51686db32696e94cb83ca2ce576a5508272e016fe4 SHA512 c1e82867c0be8a0a38d05ecee04568c3c4eebff85d8c1b90713e3ca953197da7a857d8dc20083afc4fa4b92cc5e43a8aabe8022bc104394acbe6a0aba7602613
diff --git a/dev-python/tenacity/tenacity-8.2.3.ebuild b/dev-python/tenacity/tenacity-8.2.3.ebuild
new file mode 100644
index 000000000000..1dfd2761517b
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+ fi
+
+ epytest
+}