summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-30 09:59:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-30 10:17:02 +0200
commitb8361dce3861ee7a8198b727031c46c0b9403eec (patch)
treef22ae84c24856f8d2569f3981460586455f59b50 /dev-python/terminado
parentdev-libs/libfido2: Bump to version 1.7.0 (diff)
downloadgentoo-b8361dce3861ee7a8198b727031c46c0b9403eec.tar.gz
gentoo-b8361dce3861ee7a8198b727031c46c0b9403eec.tar.bz2
gentoo-b8361dce3861ee7a8198b727031c46c0b9403eec.zip
dev-python/terminado: Bump to 0.9.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/terminado')
-rw-r--r--dev-python/terminado/Manifest1
-rw-r--r--dev-python/terminado/terminado-0.9.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/terminado/Manifest b/dev-python/terminado/Manifest
index a85a3ad8de98..7e89fa8a8769 100644
--- a/dev-python/terminado/Manifest
+++ b/dev-python/terminado/Manifest
@@ -1,2 +1,3 @@
DIST terminado-0.8.3.tar.gz 21165 BLAKE2B ec031cb7828840a4f299aa25de0030d5b7993119fd41b71e698dd032f4fd31ea725a9b610dc53a71d480ee74b49a1d072d76555b434da4f5fee2479efa03fdec SHA512 441355cdc919b6f04b1bf1eb870f24e0bd6c7ef412e72e1747707049b1fa0d6676644e3646007f2653b3df00e1f30048d9dc40d73f0827b2bbfc0821549e140b
DIST terminado-0.9.1.tar.gz 12335 BLAKE2B 7f4d7794b8bccb3d7eafd5ab35130521633c391d19fcc93e02c24f3937c7f186e786d12047dde066807ee2ace3ee7db4f0607fc9c10dc976344c32398b5da23b SHA512 429d2417cfc5521ee471febae6d893764cc0f1c7024c272951a178db5e2d20ce64af499393cd020ff6b424dc8b07d69a70da5789b39b49510a5789351a6f04f4
+DIST terminado-0.9.4.tar.gz 13934 BLAKE2B 8544d70a7c561005370bbb2b16db593ac9e4453b729b58d641b99066dc1255e294b712958d54a35a92d85e30b918a1122d24e97400b967858b542498d76305b5 SHA512 ab297e60c1adb25b5fbfcd0246db12f5df3acceeac3357af310602da3915345cb2d4fb460cc303cc4b5b5df237e750ce123ac0ed98a9bf7c6e8493783398cbc9
diff --git a/dev-python/terminado/terminado-0.9.4.ebuild b/dev-python/terminado/terminado-0.9.4.ebuild
new file mode 100644
index 000000000000..45482f499c02
--- /dev/null
+++ b/dev-python/terminado/terminado-0.9.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.org/project/terminado/ https://github.com/jupyter/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ distutils-r1_src_test
+}