summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 12:27:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 12:56:23 +0200
commitbc68b1e22d3ccb77693c7d85471efc22c6929592 (patch)
tree914c2a7d2c0e6d63fd483bbbbcad195ecb57faad /dev-python/testscenarios
parentdev-python/fixtures: Port to py3.10 (diff)
downloadgentoo-bc68b1e22d3ccb77693c7d85471efc22c6929592.tar.gz
gentoo-bc68b1e22d3ccb77693c7d85471efc22c6929592.tar.bz2
gentoo-bc68b1e22d3ccb77693c7d85471efc22c6929592.zip
dev-python/testscenarios: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild b/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild
index ef33bdf56770..48131c36af92 100644
--- a/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild
+++ b/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A pyunit extension for dependency injection"
@@ -14,20 +13,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/testtools[${PYTHON_USEDEP}]"
# using pytest for tests since unittest loader fails with py3.5+
-DEPEND="
+BDEPEND="
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
-python_prepare_all() {
- # Remove a faulty file from tests, missing a required attribute
- rm ${PN}/tests/test_testcase.py || die
- distutils-r1_python_prepare_all
+python_test() {
+ epytest --deselect testscenarios/tests/test_testcase.py
}