summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-16 19:06:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-16 19:08:27 +0200
commit0efd814b12af479b6a6af09f0adee3ac33cece5a (patch)
treeb3f5cb6c296b8f1a4f67cf9986259c9d9aac09c0 /dev-python/testtools
parentdev-python/python-socks: Remove old (diff)
downloadgentoo-0efd814b12af479b6a6af09f0adee3ac33cece5a.tar.gz
gentoo-0efd814b12af479b6a6af09f0adee3ac33cece5a.tar.bz2
gentoo-0efd814b12af479b6a6af09f0adee3ac33cece5a.zip
dev-python/testtools: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/Manifest1
-rw-r--r--dev-python/testtools/files/testtools-2.5.0-py311.patch116
-rw-r--r--dev-python/testtools/testtools-2.5.0-r1.ebuild60
3 files changed, 0 insertions, 177 deletions
diff --git a/dev-python/testtools/Manifest b/dev-python/testtools/Manifest
index 1a6a401d0768..4a587c79bd1a 100644
--- a/dev-python/testtools/Manifest
+++ b/dev-python/testtools/Manifest
@@ -1,2 +1 @@
-DIST testtools-2.5.0.tar.gz 235399 BLAKE2B 62d62cd12f19eb3fad419dc06e7f0152bf8f70a9f60927b1d791f2905b34e13199ceac93b3d30735acae2c5db1e8554cc5a7f6c8588d1f05fb213c424e90a12b SHA512 6adbf9e90f0647a44130e99cd94e4c0cbfab3a1b5c28b6bb124d061defe69d8043186cfe554099936effe16a6b07d59927bfeb6820f5a0fb34970ff243030fd4
DIST testtools-2.6.0.tar.gz 237864 BLAKE2B 1540c3b6d0f98adccf69e281778cf5ce685cf5b63102f0ee260bc6d1a8cedef0f57a81506e13b705a452f22dd75858da08a7f577b39279b2ae05643b4e96338e SHA512 309893693b2ae63ff75395bf543bd42caa9aee3b1208ce5921d893b3635012f6aa8ed5e797b4d130d83e1b530778e87b91e57b901e8351f86d44f3289d54d04b
diff --git a/dev-python/testtools/files/testtools-2.5.0-py311.patch b/dev-python/testtools/files/testtools-2.5.0-py311.patch
deleted file mode 100644
index ee457f6119c3..000000000000
--- a/dev-python/testtools/files/testtools-2.5.0-py311.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-From 77953cf633ecd149b2c29e616f8d9d4e0cf8e5fa Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@canonical.com>
-Date: Sat, 23 Apr 2022 22:53:48 +0100
-Subject: [PATCH] Fix various test failures with Python 3.11
-
-The changes for https://peps.python.org/pep-0657/ require a number of
-changes in our tests.
-
-Some tests still fail due to
-https://twistedmatrix.com/trac/ticket/10336, so I'm not adding
-3.11 to the test matrix yet.
-
-Fixes #325.
----
- testtools/tests/test_run.py | 4 ++--
- testtools/tests/test_testresult.py | 23 +++++++++++++----------
- testtools/tests/test_testsuite.py | 2 +-
- 3 files changed, 16 insertions(+), 13 deletions(-)
-
-diff --git a/testtools/tests/test_run.py b/testtools/tests/test_run.py
-index ee96eec9..9808421b 100644
---- a/testtools/tests/test_run.py
-+++ b/testtools/tests/test_run.py
-@@ -202,9 +202,9 @@ def test_run_list_failed_import(self):
- Failed to import test module: runexample
- Traceback (most recent call last):
- File ".../loader.py", line ..., in _find_test_path
-- package = self._get_module_from_name(name)
-+ package = self._get_module_from_name(name)...
- File ".../loader.py", line ..., in _get_module_from_name
-- __import__(name)
-+ __import__(name)...
- File ".../runexample/__init__.py", line 1
- class not in
- ...^...
-diff --git a/testtools/tests/test_testresult.py b/testtools/tests/test_testresult.py
-index 4fbf15d1..7824ff46 100644
---- a/testtools/tests/test_testresult.py
-+++ b/testtools/tests/test_testresult.py
-@@ -1266,11 +1266,11 @@ def test_traceback_formatting_without_stack_hidden(self):
- DocTestMatches(
- 'Traceback (most recent call last):\n'
- ' File "...testtools...runtest.py", line ..., in _run_user\n'
-- ' return fn(*args, **kwargs)\n'
-+ ' return fn(*args, **kwargs)\n...'
- ' File "...testtools...testcase.py", line ..., in _run_test_method\n'
-- ' return self._get_test_method()()\n'
-+ ' return self._get_test_method()()\n...'
- ' File "...testtools...tests...test_testresult.py", line ..., in error\n'
-- ' 1/0\n'
-+ ' 1/0\n...'
- 'ZeroDivisionError: ...\n',
- doctest.ELLIPSIS | doctest.REPORT_UDIFF))
-
-@@ -1283,7 +1283,7 @@ def test_traceback_formatting_with_stack_hidden(self):
- DocTestMatches(
- 'Traceback (most recent call last):\n'
- ' File "...testtools...tests...test_testresult.py", line ..., in error\n'
-- ' 1/0\n'
-+ ' 1/0\n...'
- 'ZeroDivisionError: ...\n',
- doctest.ELLIPSIS))
-
-@@ -1322,17 +1322,17 @@ def test_traceback_with_locals(self):
- DocTestMatches(
- 'Traceback (most recent call last):\n'
- ' File "...testtools...runtest.py", line ..., in _run_user\n'
-- ' return fn(*args, **kwargs)\n'
-+ ' return fn(*args, **kwargs)\n...'
- ' args = ...\n'
- ' fn = ...\n'
- ' kwargs = ...\n'
- ' self = ...\n'
- ' File "...testtools...testcase.py", line ..., in _run_test_method\n'
-- ' return self._get_test_method()()\n'
-+ ' return self._get_test_method()()\n...'
- ' result = ...\n'
- ' self = ...\n'
- ' File "...testtools...tests...test_testresult.py", line ..., in error\n'
-- ' 1/0\n'
-+ ' 1/0\n...'
- ' a = 1\n'
- ' self = ...\n'
- 'ZeroDivisionError: ...\n',
-@@ -2645,12 +2645,15 @@ def test_unprintable_exception(self):
- " raise RuntimeError\n"
- " def __repr__(self):\n"
- " raise RuntimeError\n")
-+ if sys.version_info >= (3, 11):
-+ expected = "UnprintableError: <exception str() failed>\n"
-+ else:
-+ expected = (
-+ "UnprintableError: <unprintable UnprintableError object>\n")
- textoutput = self._test_external_case(
- modulelevel=exception_class,
- testline="raise UnprintableError")
-- self.assertIn(self._as_output(
-- "UnprintableError: <unprintable UnprintableError object>\n"),
-- textoutput)
-+ self.assertIn(self._as_output(expected), textoutput)
-
- def test_non_ascii_dirname(self):
- """Script paths in the traceback can be non-ascii"""
-diff --git a/testtools/tests/test_testsuite.py b/testtools/tests/test_testsuite.py
-index 65cb88d7..01abb23c 100644
---- a/testtools/tests/test_testsuite.py
-+++ b/testtools/tests/test_testsuite.py
-@@ -178,7 +178,7 @@ def run(self):
- "Traceback (most recent call last):\n")
- self.assertThat(events[2][6].decode('utf8'), DocTestMatches("""\
- File "...testtools/testsuite.py", line ..., in _run_test
-- test.run(process_result)
-+ test.run(process_result)...
- """, doctest.ELLIPSIS))
- self.assertThat(events[3][6].decode('utf8'), DocTestMatches("""\
- TypeError: ...run() takes ...1 ...argument...2...given...
diff --git a/dev-python/testtools/testtools-2.5.0-r1.ebuild b/dev-python/testtools/testtools-2.5.0-r1.ebuild
deleted file mode 100644
index 47987f955024..000000000000
--- a/dev-python/testtools/testtools-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the Python standard library unit testing framework"
-HOMEPAGE="
- https://github.com/testing-cabal/testtools/
- https://pypi.org/project/testtools/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/extras-1.0.0[${PYTHON_USEDEP}]
- dev-python/python-mimeparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- )
-"
-PDEPEND="
- >=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx doc
-
-PATCHES=(
- # https://github.com/testing-cabal/testtools/pull/328
- "${FILESDIR}"/${P}-py311.patch
-)
-
-src_prepare() {
- # very fragile to formatting changes (broken on py3.10 & pypy3)
- sed -i -e 's:test_syntax_error(:_&:' \
- testtools/tests/test_testresult.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite ||
- die "tests failed under ${EPYTHON}"
-}