summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-16 12:50:17 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-16 12:50:17 +0200
commitf052b4b412bd5b929b79299aa7076127fa1d25ce (patch)
tree6c183d47fd20e77bec63d0acf052d2e40348d154 /dev-python/testtools
parentdev-python/testtools: Backport fices for tests (diff)
downloadgentoo-f052b4b412bd5b929b79299aa7076127fa1d25ce.tar.gz
gentoo-f052b4b412bd5b929b79299aa7076127fa1d25ce.tar.bz2
gentoo-f052b4b412bd5b929b79299aa7076127fa1d25ce.zip
dev-python/testtools: Backport some more commits needed for tests on py3
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/files/testtools-1.8.0-twisted-backport1.patch33
-rw-r--r--dev-python/testtools/files/testtools-1.8.0-twisted-backport2.patch57
-rw-r--r--dev-python/testtools/testtools-1.8.0.ebuild2
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/testtools/files/testtools-1.8.0-twisted-backport1.patch b/dev-python/testtools/files/testtools-1.8.0-twisted-backport1.patch
new file mode 100644
index 000000000000..c1eb11b1f5ab
--- /dev/null
+++ b/dev-python/testtools/files/testtools-1.8.0-twisted-backport1.patch
@@ -0,0 +1,33 @@
+From 6d821b5770b01f5ec98c3b8db734fffeebf12b62 Mon Sep 17 00:00:00 2001
+From: Colin Watson <cjwatson@canonical.com>
+Date: Mon, 24 Aug 2015 13:21:57 +0100
+Subject: [PATCH] Test with Twisted 13.0.0/15.2.0.
+
+---
+ .travis.yml | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/.travis.yml b/.travis.yml
+index 41036f8..a706b27 100644
+--- a/.travis.yml
++++ b/.travis.yml
+@@ -7,6 +7,10 @@ python:
+ - "3.4"
+ - "pypy"
+
++env:
++ - TWISTED="==13.0.0"
++ - TWISTED="==15.2.0"
++
+ # We have to pin Jinja2 < 2.7 for Python 3.2 because 2.7 drops/breaks support:
+ # http://jinja.pocoo.org/docs/changelog/#version-2-7
+ # And Spinx to < 1.3 for pypy3 and python 3.2 similarly.
+@@ -23,7 +27,7 @@ matrix:
+ env: SPHINX="<1.3"
+
+ install:
+- - pip install fixtures $JINJA_REQ sphinx$SPHINX
++ - pip install fixtures $JINJA_REQ sphinx$SPHINX Twisted$TWISTED
+ - python setup.py install
+
+ script:
diff --git a/dev-python/testtools/files/testtools-1.8.0-twisted-backport2.patch b/dev-python/testtools/files/testtools-1.8.0-twisted-backport2.patch
new file mode 100644
index 000000000000..df5d91f9b681
--- /dev/null
+++ b/dev-python/testtools/files/testtools-1.8.0-twisted-backport2.patch
@@ -0,0 +1,57 @@
+From 2e03ffaff15bc5d83c5f6d092aab4072f166aca0 Mon Sep 17 00:00:00 2001
+From: Colin Watson <cjwatson@canonical.com>
+Date: Mon, 24 Aug 2015 13:45:01 +0100
+Subject: [PATCH] Only run Twisted tests on Python 2.
+
+---
+ .travis.yml | 22 ++++++++++++++++------
+ 1 file changed, 16 insertions(+), 6 deletions(-)
+
+diff --git a/.travis.yml b/.travis.yml
+index a706b27..bc007f2 100644
+--- a/.travis.yml
++++ b/.travis.yml
+@@ -7,27 +7,37 @@ python:
+ - "3.4"
+ - "pypy"
+
+-env:
+- - TWISTED="==13.0.0"
+- - TWISTED="==15.2.0"
+-
+ # We have to pin Jinja2 < 2.7 for Python 3.2 because 2.7 drops/breaks support:
+ # http://jinja.pocoo.org/docs/changelog/#version-2-7
+-# And Spinx to < 1.3 for pypy3 and python 3.2 similarly.
++# And Sphinx to < 1.3 for pypy3 and python 3.2 similarly.
+ #
+ # See also:
+ # http://stackoverflow.com/questions/18252804/syntax-error-in-jinja-2-library
++#
++# Twisted tests currently only work on Python 2.
+ matrix:
+ include:
++ - python: "2.6"
++ env:
++ - TWISTED_REQ="Twisted==13.0.0"
++ - TWISTED_REQ="Twisted==15.2.0"
++ - python: "2.7"
++ env:
++ - TWISTED_REQ="Twisted==13.0.0"
++ - TWISTED_REQ="Twisted==15.2.0"
+ - python: "3.2"
+ env:
+ - JINJA_REQ="jinja2<2.7, Pygments<2.0"
+ - SPHINX="<1.3"
++ - python: "pypy"
++ env:
++ - TWISTED_REQ="Twisted==13.0.0"
++ - TWISTED_REQ="Twisted==15.2.0"
+ - python: "pypy3"
+ env: SPHINX="<1.3"
+
+ install:
+- - pip install fixtures $JINJA_REQ sphinx$SPHINX Twisted$TWISTED
++ - pip install fixtures $JINJA_REQ sphinx$SPHINX $TWISTED_REQ
+ - python setup.py install
+
+ script:
diff --git a/dev-python/testtools/testtools-1.8.0.ebuild b/dev-python/testtools/testtools-1.8.0.ebuild
index 8c538f808584..33679b9901e0 100644
--- a/dev-python/testtools/testtools-1.8.0.ebuild
+++ b/dev-python/testtools/testtools-1.8.0.ebuild
@@ -33,6 +33,8 @@ RDEPEND="${CDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-twisted-backport.patch
+ "${FILESDIR}"/${P}-twisted-backport1.patch
+ "${FILESDIR}"/${P}-twisted-backport2.patch
)
python_compile_all() {