summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-20 05:07:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-20 05:49:53 +0100
commit46edfca810edd4ab1920e040dc87a9cccdb26140 (patch)
tree180286700c94507eca491195394c2ceaa0cb63a8 /dev-python/trove-classifiers
parentapp-admin/awscli: Bump to 1.27.53 (diff)
downloadgentoo-46edfca810edd4ab1920e040dc87a9cccdb26140.tar.gz
gentoo-46edfca810edd4ab1920e040dc87a9cccdb26140.tar.bz2
gentoo-46edfca810edd4ab1920e040dc87a9cccdb26140.zip
dev-python/trove-classifiers: Bump to 2023.1.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.1.20.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 3a99ccc0a67d..bcb1f9bd5eda 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,2 +1,3 @@
DIST trove-classifiers-2022.12.22.gh.tar.gz 15036 BLAKE2B ad66020fdd9c05e905df1700e5dc6f3b195d3ac50cf289e8aca9f19c4bc55cb2426f0d019a3bb2b77e9c7f095eb5f36dad97c0e8191009fed0a2faf8f47588bb SHA512 a9883775154a873f62d6fc20b090d75467a17a364459bb958a0dcef402e9b3133a791e683f74b65fa90c4601a62365eef96ade9f7eef0f7290ce1d13bae0abf0
DIST trove-classifiers-2023.1.12.gh.tar.gz 15052 BLAKE2B 35234389370f1f56e39be8b6b791e1cb00d77903ed672de6e465a0866cac968eceaf1776c102db18efaee2e6b2b48edd4c317ca95f53d6d90503c7a5f35fb21f SHA512 c56e2912f7553a8ddb0e982116cc6016ffa2bbde3714d23d1c2733dc4096d328500ae835fa4d291575e2b06ae194c5928873b925943df09e663d7f28d7d2048b
+DIST trove-classifiers-2023.1.20.gh.tar.gz 15075 BLAKE2B 04b5902c0318d495be8ef5f3602ae93d0a540f34382dd269202f4b0e6773d9c0adf023df9c45afece0ae27da8dad25d0018b602dc2a02e775c40ea73afb77195 SHA512 f99dee6f42ef3d1e42d0d1f520d882af2d430133a317de693464a526849bf6d9990307c189b5bacf2fa97c316d0c806ecfe9cfcd05a6734e79992763f597dfd2
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.1.20.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.1.20.ebuild
new file mode 100644
index 000000000000..850f0b5ffda7
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.1.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}