summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-16 06:56:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-16 07:10:57 +0100
commit72f9fec4aa5e5c40a549dc68f8a9f08efcc07bc6 (patch)
treee7f03bb1fa776b791ea1fdd9ce66efe7716cf7a2 /dev-python/txaio/txaio-23.1.1.ebuild
parentdev-python/ytmusicapi: Remove old (diff)
downloadgentoo-72f9fec4aa5e5c40a549dc68f8a9f08efcc07bc6.tar.gz
gentoo-72f9fec4aa5e5c40a549dc68f8a9f08efcc07bc6.tar.bz2
gentoo-72f9fec4aa5e5c40a549dc68f8a9f08efcc07bc6.zip
dev-python/txaio: Bump to 23.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/txaio/txaio-23.1.1.ebuild')
-rw-r--r--dev-python/txaio/txaio-23.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/txaio/txaio-23.1.1.ebuild b/dev-python/txaio/txaio-23.1.1.ebuild
new file mode 100644
index 000000000000..8a5a87523478
--- /dev/null
+++ b/dev-python/txaio/txaio-23.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="
+ https://github.com/crossbario/txaio/
+ https://pypi.org/project/txaio/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinxcontrib-spelling-2.1.2' \
+ '>=dev-python/sphinx_rtd_theme-0.1.9'
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # we certainly don't need to test "python setup.py sdist" here
+ test/test_packaging.py
+)
+
+pkg_postinst() {
+ optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"
+}