summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-27 17:42:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-27 17:42:32 +0200
commitebd708d7d02517ac2f8a5c58499391ceeb47a0a1 (patch)
tree020a7a6b48099b06028fd173020263b013c22449 /dev-python/typeguard
parentdev-python/tomlkit: Bump to 0.12.1 (diff)
downloadgentoo-ebd708d7d02517ac2f8a5c58499391ceeb47a0a1.tar.gz
gentoo-ebd708d7d02517ac2f8a5c58499391ceeb47a0a1.tar.bz2
gentoo-ebd708d7d02517ac2f8a5c58499391ceeb47a0a1.zip
dev-python/typeguard: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.0.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 4ce05572df81..7ac0f2101d5e 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-4.0.0.tar.gz 66064 BLAKE2B 250ef359fedb83df7573c9acb97f80fbf1d5b949505deb3d3757422aedadda65a106bf9533d858e13e2c49e0212a40a8604fa2edc8b24903e374a678985f4c85 SHA512 2acf8b9aabaa8d4cce75e1ff23aeae4d1445bdfc28044c74b8e96127b1e740287e5da89bd49bea92229ba5c02c7cec3b0e25126fa35eb5163b798b2087b1df6a
+DIST typeguard-4.0.1.tar.gz 67242 BLAKE2B bf0b092402e4044675f1252a1ad4657fa8ec316bfda5e0afcce609f616e8d86998c059544ebbeea73eb5fa627eeae9371d46581b33891319f7b2385faa359310 SHA512 2e93086309550d6b98f2087a8900797ab9486c1a969da649d1a6cb508f6154b57b6807762e87df43088f80b69bcc11f87c71d83b38ca205d3ad8878a2cd4eb0e
diff --git a/dev-python/typeguard/typeguard-4.0.1.ebuild b/dev-python/typeguard/typeguard-4.0.1.ebuild
new file mode 100644
index 000000000000..2d5d1842fcbf
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.7.0[${PYTHON_USEDEP}]
+ ' 3.{10..11})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False
+}