summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-24 16:50:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-24 17:22:28 +0100
commitfd747c127909b549c7b43a7b82ba25a772089ee7 (patch)
treefb6825aa18bd267e06f43d4e3faad75eb6ffd38f /dev-python/typeguard
parentdev-python/click-didyoumean: Bump to 0.3.1 (diff)
downloadgentoo-fd747c127909b549c7b43a7b82ba25a772089ee7.tar.gz
gentoo-fd747c127909b549c7b43a7b82ba25a772089ee7.tar.bz2
gentoo-fd747c127909b549c7b43a7b82ba25a772089ee7.zip
dev-python/typeguard: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index e9185bd41c56..397c03f3d417 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-4.1.5.tar.gz 69228 BLAKE2B 2af39b1cb179483e167b8cfbf053e633f5947b3a17c496aaa2bdf22f3a69f7b41e2c9f317534eb12ffb781364cf81d117ced9fafd389aadd85d16d05e42bff0b SHA512 50bf3760246dba5de2e98038c78acbd6f2fd2d69ae8c688c3efeface5ef6cc4c2521f82d6084dabc1258286ac589ff94f1b9e3c9b67e9b019d725bf13884fce2
+DIST typeguard-4.2.1.tar.gz 71292 BLAKE2B ad529ce88c7d38d4491734c5ac8e465bbde66ccd76a18f83c0f61837fa10c50450bc8535bbab48e913cea9593795a6b16d82650eed38c277f65cd5d5556d71a1 SHA512 2bfe2836cbcca0f223d16e5772c9c53169b75391f062eb6fc5f1abc22297b7482f3482812f15b3ed92dd31b86f803072245370dce5ba19fc4d31723b1d2f38b3
diff --git a/dev-python/typeguard/typeguard-4.2.1.ebuild b/dev-python/typeguard/typeguard-4.2.1.ebuild
new file mode 100644
index 000000000000..9cd2a29b277d
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.10.0[${PYTHON_USEDEP}]
+ ' 3.{10..12})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False -p typeguard
+}