summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-16 21:40:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-16 21:41:26 +0300
commit82870fab6b42ac34b948e12ba6286712775ffbca (patch)
tree86d9eaff0e38c7fc186e45bf3009f219765c4215 /dev-python/utidylib
parentdev-python/url-normalize: enable py3.11 (diff)
downloadgentoo-82870fab6b42ac34b948e12ba6286712775ffbca.tar.gz
gentoo-82870fab6b42ac34b948e12ba6286712775ffbca.tar.bz2
gentoo-82870fab6b42ac34b948e12ba6286712775ffbca.zip
dev-python/utidylib: PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/utidylib-0.7-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/utidylib/utidylib-0.7-r3.ebuild b/dev-python/utidylib/utidylib-0.7-r3.ebuild
new file mode 100644
index 000000000000..e2b6fdd88cbe
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.7-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="https://github.com/nijel/utidylib/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=app-text/htmltidy-5.0.0"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)