summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 10:43:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 11:09:37 +0200
commitb6b84926d7974b3ef5bc48ad91b18a9472e89e11 (patch)
tree12dd24057f2038e705452670e87ec23c7e40bdd7 /dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
parentnet-misc/electrum: Make qdarkstyle dep optional (diff)
downloadgentoo-b6b84926d7974b3ef5bc48ad91b18a9472e89e11.tar.gz
gentoo-b6b84926d7974b3ef5bc48ad91b18a9472e89e11.tar.bz2
gentoo-b6b84926d7974b3ef5bc48ad91b18a9472e89e11.zip
dev-python/virtualenv-clone: Bump to 0.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild')
-rw-r--r--dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild b/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
new file mode 100644
index 000000000000..d7c7d6520d7c
--- /dev/null
+++ b/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A script for cloning a non-relocatable virtualenv"
+HOMEPAGE="
+ https://github.com/edwardgeorge/virtualenv-clone/
+ https://pypi.org/project/virtualenv-clone/
+"
+SRC_URI="
+ https://github.com/edwardgeorge/virtualenv-clone/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest