summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2022-10-12 08:30:09 +0200
committerEray Aslan <eras@gentoo.org>2022-10-12 08:31:04 +0200
commit37570b3adef0ffa5e9aba77b9a770f7521b6b13e (patch)
treee4dbb24f29569208e8e2c43f3a6d771bfd21c77b /dev-python/virtualenvwrapper
parentdev-python/python-docs: Bump to 3.8.15 (diff)
downloadgentoo-37570b3adef0ffa5e9aba77b9a770f7521b6b13e.tar.gz
gentoo-37570b3adef0ffa5e9aba77b9a770f7521b6b13e.tar.bz2
gentoo-37570b3adef0ffa5e9aba77b9a770f7521b6b13e.zip
dev-python/virtualenvwrapper: do not install namespace packages
update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/876367 Closes: https://bugs.gentoo.org/798609 Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'dev-python/virtualenvwrapper')
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild
new file mode 100644
index 000000000000..13f088a96ea5
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="https://bitbucket.org/dhellmann/virtualenvwrapper
+ https://pypi.org/project/virtualenvwrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i -e 's/egrep/grep -E/' "${S}/virtualenvwrapper.sh" || die
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}