summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 11:49:48 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 11:49:48 +0200
commit351190af49b1a1198e6364e26b8d852adf1c2862 (patch)
tree815b5e84c83b7a5e0a27774419c1bad82309ba27 /dev-python/weasyprint/weasyprint-0.29.ebuild
parentdev-python/pyphen: Add py3.5 support (diff)
downloadgentoo-351190af49b1a1198e6364e26b8d852adf1c2862.tar.gz
gentoo-351190af49b1a1198e6364e26b8d852adf1c2862.tar.bz2
gentoo-351190af49b1a1198e6364e26b8d852adf1c2862.zip
dev-python/weasyprint: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/weasyprint/weasyprint-0.29.ebuild')
-rw-r--r--dev-python/weasyprint/weasyprint-0.29.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/weasyprint/weasyprint-0.29.ebuild b/dev-python/weasyprint/weasyprint-0.29.ebuild
new file mode 100644
index 000000000000..bf9f36de9ff6
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.29.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+RDEPEND="x11-libs/pango:0/0
+ >=media-gfx/cairosvg-1.0.7[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/cairocffi-0.5[${PYTHON_USEDEP}]
+ ~dev-python/tinycss-0.3[${PYTHON_USEDEP}]
+ >=dev-python/cssselect-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]"
+# x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}