summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-18 10:07:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-18 10:19:09 +0200
commit41670abfce09dfa3e524c0dc63e2a94b7d95f24f (patch)
tree7581a6c92048f6f4e12aceb6817c5f064ea4f156 /dev-python/websockets/websockets-10.3.ebuild
parentdev-python/zstd: Bump to 1.5.2.2 (diff)
downloadgentoo-41670abfce09dfa3e524c0dc63e2a94b7d95f24f.tar.gz
gentoo-41670abfce09dfa3e524c0dc63e2a94b7d95f24f.tar.bz2
gentoo-41670abfce09dfa3e524c0dc63e2a94b7d95f24f.zip
dev-python/websockets: Bump to 10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets/websockets-10.3.ebuild')
-rw-r--r--dev-python/websockets/websockets-10.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/websockets/websockets-10.3.ebuild b/dev-python/websockets/websockets-10.3.ebuild
new file mode 100644
index 000000000000..1723d0a7cdd0
--- /dev/null
+++ b/dev-python/websockets/websockets-10.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/aaugustin/websockets/
+ https://pypi.org/project/websockets/
+"
+SRC_URI="
+ https://github.com/aaugustin/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ )
+
+ epytest tests
+}