summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 10:35:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 10:43:26 +0200
commit8f041477bdd17213149e32f81ae2e9e4f1f1f4e2 (patch)
tree1a40a2ade4eef422cc4545db41b161fb01fee9ea /dev-python/websockets/websockets-10.3.ebuild
parentdev-python/editables: Stabilize 0.3 ppc, #844823 (diff)
downloadgentoo-8f041477bdd17213149e32f81ae2e9e4f1f1f4e2.tar.gz
gentoo-8f041477bdd17213149e32f81ae2e9e4f1f1f4e2.tar.bz2
gentoo-8f041477bdd17213149e32f81ae2e9e4f1f1f4e2.zip
dev-python/websockets: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets/websockets-10.3.ebuild')
-rw-r--r--dev-python/websockets/websockets-10.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/websockets/websockets-10.3.ebuild b/dev-python/websockets/websockets-10.3.ebuild
index 8ae85335baa3..ab47cfe892ef 100644
--- a/dev-python/websockets/websockets-10.3.ebuild
+++ b/dev-python/websockets/websockets-10.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
@@ -25,6 +25,10 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/${P}-py311.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=(
# very fragile to speed