summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 13:46:04 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 13:46:38 -0800
commite1762668f2a4524e16f5026db167b9b5af03645f (patch)
treeb08c420cfb2b4f2f9d3f4a8ee3aaf28b422a3055 /dev-python/webtest
parentdev-util/patchelf: arm64 stable (bug #700634) (diff)
downloadgentoo-e1762668f2a4524e16f5026db167b9b5af03645f.tar.gz
gentoo-e1762668f2a4524e16f5026db167b9b5af03645f.tar.bz2
gentoo-e1762668f2a4524e16f5026db167b9b5af03645f.zip
dev-python/webtest: Version bump to 2.0.33
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/Manifest1
-rw-r--r--dev-python/webtest/files/webtest-2.0.33-no-pylons-theme.patch51
-rw-r--r--dev-python/webtest/webtest-2.0.33.ebuild79
3 files changed, 131 insertions, 0 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
index 87d4771de373..4ac12673163b 100644
--- a/dev-python/webtest/Manifest
+++ b/dev-python/webtest/Manifest
@@ -1,2 +1,3 @@
DIST WebTest-2.0.21.tar.gz 66866 BLAKE2B d2830fcce7fb4b91029838806952e3e9c6916c3b292c7142138f30486d936b4a1f0c2d28a5973b0c351c64e499f343f3711296c6e37c38548e3a81b108163a17 SHA512 21f58ee9192fd0eb0eb2d88179ffc015aa5cf04c8004db251bd65d13d54c34b9e6b5fc9fdd8e9fcbbc18fcfb2be714c0691b2ef034318861262f8705b4a44610
DIST WebTest-2.0.29.tar.gz 74620 BLAKE2B 7fc68f1178b1abb0a0f126112b846853762ad78cb060718bc340f5ba17517180b7283f384503ff77a2c7396645ebe2d5528dbc0f027c5d44beb002c4204bf894 SHA512 319700d1444f6a681f8ed8a4ee8661ba0462b3f4bfeb7510232f58be92e017066da3bac494ebe1a3c5b9f2d06c025e08e6193277e13c6113e9485108d4ccd2d2
+DIST WebTest-2.0.33.tar.gz 76081 BLAKE2B 6c06d7cf6573282342ac190fe2365d041679fd9a75571a525cf0214f22a0631d5f97e94261090d9c2a372f77b005d22be5976f612c27c6b4c832c71469b33ee8 SHA512 9f5c614f8215837dc5cecc9c3e844c5e1678eb8275f9e27a0ec6a68648e9f4f09155aa72f6c731c34028b8671b7776a94235f3e54d7dbf5ff55de94840171ca8
diff --git a/dev-python/webtest/files/webtest-2.0.33-no-pylons-theme.patch b/dev-python/webtest/files/webtest-2.0.33-no-pylons-theme.patch
new file mode 100644
index 000000000000..3fe4fe3770e2
--- /dev/null
+++ b/dev-python/webtest/files/webtest-2.0.33-no-pylons-theme.patch
@@ -0,0 +1,51 @@
+diff --git a/docs/conf.py b/docs/conf.py
+index 96746bf..2445d35 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -13,7 +13,7 @@
+
+ import sys, os
+ import datetime
+-import pylons_sphinx_themes
++#import pylons_sphinx_themes
+
+ # If extensions (or modules to document with autodoc) are in another directory,
+ # add these directories to sys.path here. If the directory is relative to the
+@@ -102,11 +102,11 @@ pygments_style = 'sphinx'
+
+ # The theme to use for HTML and HTML Help pages. See the documentation for
+ # a list of builtin themes.
+-html_theme = 'pylons'
+-html_theme_path = pylons_sphinx_themes.get_html_themes_path()
+-html_theme_options = dict(
+- github_url='https://github.com/Pylons/webtest',
+- )
++#html_theme = 'pylons'
++#html_theme_path = pylons_sphinx_themes.get_html_themes_path()
++#html_theme_options = dict(
++# github_url='https://github.com/Pylons/webtest',
++# )
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the
+ # documentation.
+@@ -180,13 +180,13 @@ smartquotes = False
+ htmlhelp_basename = 'WebTestdoc'
+
+ # Control display of sidebars
+-html_sidebars = { '**': [
+- 'localtoc.html',
+- 'ethicalads.html',
+- 'relations.html',
+- 'sourcelink.html',
+- 'searchbox.html',
+-] }
++#html_sidebars = { '**': [
++# 'localtoc.html',
++# 'ethicalads.html',
++# 'relations.html',
++# 'sourcelink.html',
++# 'searchbox.html',
++#] }
+
+ # -- Options for LaTeX output --------------------------------------------------
+
diff --git a/dev-python/webtest/webtest-2.0.33.ebuild b/dev-python/webtest/webtest-2.0.33.ebuild
new file mode 100644
index 000000000000..f7c319ecf357
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.33.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="https://pypi.org/project/WebTest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Makes testing easier; otherwise we get errors from pkg_resources.
+#DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
+)
+
+python_check_deps() {
+ use doc || return 0
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -i -e 's:^intersphinx_mapping:disabled_&: ; s:^templates_path:#&:' \
+ docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ # Tests raise ImportErrors with our default PYTHONPATH.
+ local -x PYTHONPATH=
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}