summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 08:37:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 09:21:08 +0200
commitd7437c850e69fd4dbcb89153f74f68627b723229 (patch)
tree91152944e5cb270589ba1f1c305ccfc935aa0535 /dev-python/xdoctest
parentdev-python/rich: Bump to 10.12.0 (diff)
downloadgentoo-d7437c850e69fd4dbcb89153f74f68627b723229.tar.gz
gentoo-d7437c850e69fd4dbcb89153f74f68627b723229.tar.bz2
gentoo-d7437c850e69fd4dbcb89153f74f68627b723229.zip
dev-python/xdoctest: Bump to 0.15.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.10.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index f504867fa252..b32294e6f834 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,2 +1,3 @@
+DIST xdoctest-0.15.10.gh.tar.gz 191579 BLAKE2B 4836b773c3cf664c825433199b13ab7d3fe2c68538517bf5594797ad3f2f894d0132034fdafbc4502a00ec7393c19473fafe15fcf0257e3565592dc9907e3d71 SHA512 18c1a2774ae9331582610e3459a02f4e4de838218e7250af071570b2318f4c14330084b9fb903d88651fc40a4ba12b686ee6f2ca165edd8155e908ae4992a840
DIST xdoctest-0.15.8.gh.tar.gz 185463 BLAKE2B a16578e6d50398ac80d950bcc9a05131880816e2ff3a15bd1489474e532f9b495d099dcea204d8375c884c6957aaaba9b276fbcb65b5717b2850314453f787f7 SHA512 ab4f991ba6e312bf6cf675c3bbeeae87c0666b96c911ee7727f64b8e4c13420bb91e0a7a955ebce73b3fb15625b52bbf1b67c6edfe91234655501060b17723d5
DIST xdoctest-0.15.9.gh.tar.gz 190313 BLAKE2B 9980752ad5742a7c4a73418a3ace408c38a6bef6cd43ee5cd1893d6cb195a7c387c5062735b2c903725898ea670e3e6d8e683d4341dcf2dc9e17a2c723107910 SHA512 6a49fbe7f2535ab86ac7047406fbcc9f7e98c964664a95a115c3d945ba8157e4e70ab8c31edae6faee932cfd5e90201d883d9b4b10e2cea9cdc8ff14b5d52d54
diff --git a/dev-python/xdoctest/xdoctest-0.15.10.ebuild b/dev-python/xdoctest/xdoctest-0.15.10.ebuild
new file mode 100644
index 000000000000..de12e44c0541
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-0.15.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest/"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme