summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-28 20:49:10 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-28 21:11:25 +0200
commit11024d0247abd7d628d9f67e404a4b850dab7fc4 (patch)
tree7635ece3ab68e9e1b4018df47b8a99706b8f2ed0 /dev-python/xlsxwriter
parentdev-python/filelock: add 3.9.0 (diff)
downloadgentoo-11024d0247abd7d628d9f67e404a4b850dab7fc4.tar.gz
gentoo-11024d0247abd7d628d9f67e404a4b850dab7fc4.tar.bz2
gentoo-11024d0247abd7d628d9f67e404a4b850dab7fc4.zip
dev-python/xlsxwriter: add 3.0.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/xlsxwriter')
-rw-r--r--dev-python/xlsxwriter/Manifest1
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/Manifest b/dev-python/xlsxwriter/Manifest
index 57ed2a081a4c..1f8917edde83 100644
--- a/dev-python/xlsxwriter/Manifest
+++ b/dev-python/xlsxwriter/Manifest
@@ -1 +1,2 @@
DIST XlsxWriter-RELEASE_3.0.3.tar.gz 35519702 BLAKE2B f4dfa6b286dda94a1a44d8168b8e17f7a37f2f59a23aa3a5ed0efa46b5d8bdcdb831e99a61924e22755c6a921c23f5c540c048152cd07363841ff09a49549c79 SHA512 92a53226aa9ee9f8493fe7171ce752f3a13ef8f3107aecbef896f17022e93bd7dbccb5e619fcbbb3598102030b190d75508d4dacce20b9643eead59a4441f6aa
+DIST XlsxWriter-RELEASE_3.0.4.gh.tar.gz 35033608 BLAKE2B 49a54380f1753077f0d9e56024a09ffd9d26540daeb03c270e892ae986c8e36fb0ce74ab96e62b1cb15adebbb51ba2093b6b1e356077433537af62ededd79d5c SHA512 e10bbbcc975ee3c2395c642c7a04e53d792b8c739c9f5acbb3858b47963a0f9b68ac565d96d4a9f9c87b104fc02b8930b0629e753d53735892e10bd17e5c1fcc
diff --git a/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild b/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild
new file mode 100644
index 000000000000..eb7598818634
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-3.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+TAG=RELEASE_${PV}
+MY_P=XlsxWriter-${TAG}
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="
+ https://github.com/jmcnamara/XlsxWriter/
+ https://pypi.org/project/XlsxWriter/
+"
+SRC_URI="
+ https://github.com/jmcnamara/XlsxWriter/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest