summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-04-24 20:54:21 +0200
committerSam James <sam@gentoo.org>2023-04-25 02:57:16 +0100
commit79178489a14a48d86cd1e1458c4ce0b1b65aaf46 (patch)
treeeceee311346943e6b5b73bbfc0a218c9dd0287f9 /dev-python/yara-python
parentapp-forensics/yara: add 4.3.1 (diff)
downloadgentoo-79178489a14a48d86cd1e1458c4ce0b1b65aaf46.tar.gz
gentoo-79178489a14a48d86cd1e1458c4ce0b1b65aaf46.tar.bz2
gentoo-79178489a14a48d86cd1e1458c4ce0b1b65aaf46.zip
dev-python/yara-python: add 4.3.1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/30738 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/Manifest1
-rw-r--r--dev-python/yara-python/yara-python-4.3.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
index cb89bd05dcc7..e80faf540170 100644
--- a/dev-python/yara-python/Manifest
+++ b/dev-python/yara-python/Manifest
@@ -1,2 +1,3 @@
DIST yara-python-4.2.3.gh.tar.gz 34465 BLAKE2B 4b9689cef21f9c712960d08c357087f0278d8c20cef3a16072a005a4f8687999aa273c02c22ea9c6d5ea9a6b609c1a6f4c51f01b04f238e9e1faeeaef275d88b SHA512 588875d820f4e1b2aa5c6bbe83814ba2756f5ed301ba652efd280d5ca9745f7388f1f9eaa3875d11de5644ce9c41dcb76eebbee86269f8d6723c7d16ffa134be
DIST yara-python-4.3.0.gh.tar.gz 37826 BLAKE2B 2a06e462af5b3ef5098b650687f1953e51f53858dc9c22b0e9358641fa20f3f5c2b7f3b824b5b8195408e3e2bfaa05afedc851a326486454d9f3eadeecd3fe33 SHA512 c45bb57179b4191e6fb5577f42abb280dad91832720ad1712de8a2ea42adc5e3604079b2d8d0020ba86ece4043e7488889a54677e10cd2bc172a1480e57f1fef
+DIST yara-python-4.3.1.gh.tar.gz 37871 BLAKE2B d8b8eac6b12dc4c5c3362e8b5396fe9ff5a0b0557488ed94257ec2b7be813c870d39f78b53b3312b6b1100f4bdc81375ebf27cd21a569c5688503b81934c3881 SHA512 78cd53f756967ef79cc742acffaeea53631ee475c07efd1506eba7e0630b2e570ba03686da1fa3247c9339faa67daf6c372913731b73233626661c0a9f575e41
diff --git a/dev-python/yara-python/yara-python-4.3.1.ebuild b/dev-python/yara-python/yara-python-4.3.1.ebuild
new file mode 100644
index 000000000000..a4fa9fa8737f
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara-python.git"
+else
+ SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =app-forensics/yara-$(ver_cut 1-2)*
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ cat >> setup.cfg <<-EOF
+ [build_ext]
+ dynamic_linking = True
+ EOF
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}