summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 18:07:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 18:11:03 +0200
commit96bef225e760a4aa97755811b9298929f2f540ea (patch)
treeece70459e52909356a1784a8c61c39fc38a98aef /dev-python/yarl
parentdev-python/multidict: Enable py3.11 (diff)
downloadgentoo-96bef225e760a4aa97755811b9298929f2f540ea.tar.gz
gentoo-96bef225e760a4aa97755811b9298929f2f540ea.tar.bz2
gentoo-96bef225e760a4aa97755811b9298929f2f540ea.zip
dev-python/yarl: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/yarl-1.7.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-1.7.2-r2.ebuild b/dev-python/yarl/yarl-1.7.2-r2.ebuild
new file mode 100644
index 000000000000..16df0c37c1eb
--- /dev/null
+++ b/dev-python/yarl/yarl-1.7.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}