summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-21 12:54:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-21 14:24:48 +0100
commit721fa525e4e2193096b398d3becd42e13237844d (patch)
tree69d025ae001da986f938c34f77ccf8c8d499e90f /dev-python/zeep/zeep-4.2.1.ebuild
parentdev-python/python-cstruct: Bump to 5.1 (diff)
downloadgentoo-721fa525e4e2193096b398d3becd42e13237844d.tar.gz
gentoo-721fa525e4e2193096b398d3becd42e13237844d.tar.bz2
gentoo-721fa525e4e2193096b398d3becd42e13237844d.zip
dev-python/zeep: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeep/zeep-4.2.1.ebuild')
-rw-r--r--dev-python/zeep/zeep-4.2.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/zeep/zeep-4.2.1.ebuild b/dev-python/zeep/zeep-4.2.1.ebuild
new file mode 100644
index 000000000000..ac22396b7e41
--- /dev/null
+++ b/dev-python/zeep/zeep-4.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
+HOMEPAGE="
+ https://docs.python-zeep.org/
+ https://github.com/mvantellingen/python-zeep/
+ https://pypi.org/project/zeep/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="async"
+
+RDEPEND="
+ >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/aioresponses[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/python-xmlsec[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest