summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 10:14:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 10:27:02 +0200
commitee1d5e14cf7c6b6801f89ac16a8a62c0c4b73047 (patch)
tree030259808998b8cf7b213a34ab1f9b0997ef4bb8 /dev-python/zeroconf
parentdev-python/bcrypt: Bump to 3.2.2 (diff)
downloadgentoo-ee1d5e14cf7c6b6801f89ac16a8a62c0c4b73047.tar.gz
gentoo-ee1d5e14cf7c6b6801f89ac16a8a62c0c4b73047.tar.bz2
gentoo-ee1d5e14cf7c6b6801f89ac16a8a62c0c4b73047.zip
dev-python/zeroconf: Bump to 0.38.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.38.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index e1984a9199c6..c19c67d810e1 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.38.4.gh.tar.gz 133770 BLAKE2B 2b7b01112957ed9456acd7ef842a010d38b2a6e589b1714ed3fd47d2b51f448bf716bdd8511b0a3f4560cdcf0cc16bad06ac73f9a42b5c5cf4154b48cafdf97b SHA512 6b0df6fed453dab2e554d4af4d807eed1108fe50fdcc41096a11944577ee8cfa0a0b30491a1ebe6d95ddc5b78c3c0cb07bd34ef279fbfca70775628667f40212
+DIST python-zeroconf-0.38.5.gh.tar.gz 134146 BLAKE2B d1ad69e8fe9f236c95862e1e415c5739a5627ed6d96b71f7af418e1f5cc9ca9c57feac34fa18d3928bdc6cf54c7d28dd30c9f259038e018746ad6a3671101225 SHA512 68ee397b567795f55e9374906761682e404ee0428b8b104c3dfedac473bbda780c086d50b598be9940a9b14e58642960dc29280036d3ff8e3fb76660806e0f54
diff --git a/dev-python/zeroconf/zeroconf-0.38.5.ebuild b/dev-python/zeroconf/zeroconf-0.38.5.ebuild
new file mode 100644
index 000000000000..86c76362ebb0
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.38.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)