summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-11 08:28:42 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-11 08:40:43 +0200
commitc0e5ba211fb2a7ff365366bb636fc726b01cee23 (patch)
tree1c84220ce625e1593633677a2912eaae46b51aa8 /dev-python/zope-exceptions
parentapp-editors/vscodium: add 1.73.1.22314 (diff)
downloadgentoo-c0e5ba211fb2a7ff365366bb636fc726b01cee23.tar.gz
gentoo-c0e5ba211fb2a7ff365366bb636fc726b01cee23.tar.bz2
gentoo-c0e5ba211fb2a7ff365366bb636fc726b01cee23.zip
dev-python/zope-exceptions: add 4.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/zope-exceptions')
-rw-r--r--dev-python/zope-exceptions/Manifest1
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/zope-exceptions/Manifest b/dev-python/zope-exceptions/Manifest
index d3cc351c6b45..5cb9f50beeae 100644
--- a/dev-python/zope-exceptions/Manifest
+++ b/dev-python/zope-exceptions/Manifest
@@ -1 +1,2 @@
DIST zope.exceptions-4.5.tar.gz 29609 BLAKE2B 63c853105d3a588418f79e877aeedf0b001bbe52eb3e6c82687127a8cc0b8e424143e75c7a77b224ede31c5db0efb1bbc126e851dbc8bef5b856615b0717f6ea SHA512 f3f75b2f9ecfe74d3bb081904750769bf331fb594d266907782b7ce7f9d062c261b2f95a50ce21cf8917c56a25899274dae466a5b59afa5ec66480182df55bd2
+DIST zope.exceptions-4.6.tar.gz 30876 BLAKE2B 9cc9a040269aa2f813018670e3692c9897fbea3a346b37e72fc54e72fb33dbaf0f14c192a76a7c40f57674caee4e17e86aec5f1d60e1c0e6a801d859d9629189 SHA512 d28a4434b27f6611040b290dcece26c1880982853092c89d5a8d74093cb9339a62834d7c3949d5ea28c4d3fc01c6f36180df22031cded6e4c963acfff65c2ec4
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
new file mode 100644
index 000000000000..89ee54d44763
--- /dev/null
+++ b/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="General purpose exceptions for Zope packages"
+HOMEPAGE="
+ https://pypi.org/project/zope.exceptions/
+ https://github.com/zopefoundation/zope.exceptions/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}