summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-11 06:08:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-11 06:19:59 +0200
commit2032cfb7f9331431e407f177c4afafa536b20eb4 (patch)
treeb299b4fa0d65c171b99d2029b8d98d8a369b832a /dev-python
parentdev-python/orjson: Bump to 3.10.4 (diff)
downloadgentoo-2032cfb7f9331431e407f177c4afafa536b20eb4.tar.gz
gentoo-2032cfb7f9331431e407f177c4afafa536b20eb4.tar.bz2
gentoo-2032cfb7f9331431e407f177c4afafa536b20eb4.zip
dev-python/gfloat: Bump to 0.3
Closes: https://bugs.gentoo.org/933491 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gfloat/Manifest1
-rw-r--r--dev-python/gfloat/gfloat-0.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/gfloat/Manifest b/dev-python/gfloat/Manifest
index 66b114c0ad1e..dd6bf5fd40f5 100644
--- a/dev-python/gfloat/Manifest
+++ b/dev-python/gfloat/Manifest
@@ -1 +1,2 @@
DIST gfloat-0.2.1.tar.gz 40460 BLAKE2B 9103140b2523c1e0f430bdf066c1625c71783d30d3d6754cd44c626ce6ca4204742188d967489ff2dba65df6ac51989551c14ee6ae66302c452c765d5a0eca20 SHA512 50bb770795b8284c9071f345667772ecd334a7c44368acf173dd65094f9fe9ac473ae0cc250f35dfafdb19d5fe039ad3258c4256fbc281feac41f192ed139cc5
+DIST gfloat-0.3.tar.gz 43790 BLAKE2B 3b6628dd6410090a684bc253965e167297f4105e3690b9ac38c0192c202fbc7e02026103723721494d4826d835b70a217114335201ab1c329d6bac02412f9e7f SHA512 2df65a3a188e99d1aa3da1b067aa3eaa9aabc22f42414b773c312d9c8dae9baf34d797f947a1646ea89e1db8f2bdb5f97a9672c292e2e0a2a8312e0e6f2fc496
diff --git a/dev-python/gfloat/gfloat-0.3.ebuild b/dev-python/gfloat/gfloat-0.3.ebuild
new file mode 100644
index 000000000000..3b16a101cbc9
--- /dev/null
+++ b/dev-python/gfloat/gfloat-0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generic floating-point types in Python"
+HOMEPAGE="
+ https://github.com/graphcore-research/gfloat/
+ https://pypi.org/project/gfloat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ml-dtypes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires mx (possibly git version), torch
+ test/test_microxcaling.py
+)