summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-18 20:55:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-18 21:01:27 +0200
commit21595fc8da27066eb90b11c2c6e24c7a43015641 (patch)
tree726f5519353702067e05f343799fd030457f4cf2 /dev-python
parentdev-python/rustworkx: Remove old (diff)
downloadgentoo-21595fc8da27066eb90b11c2c6e24c7a43015641.tar.gz
gentoo-21595fc8da27066eb90b11c2c6e24c7a43015641.tar.bz2
gentoo-21595fc8da27066eb90b11c2c6e24c7a43015641.zip
dev-python/setuptools-rust: Modernize cargo.eclass usage
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools-rust/setuptools-rust-1.6.0.ebuild152
1 files changed, 76 insertions, 76 deletions
diff --git a/dev-python/setuptools-rust/setuptools-rust-1.6.0.ebuild b/dev-python/setuptools-rust/setuptools-rust-1.6.0.ebuild
index 25805e47d8c3..d0a3d355acbf 100644
--- a/dev-python/setuptools-rust/setuptools-rust-1.6.0.ebuild
+++ b/dev-python/setuptools-rust/setuptools-rust-1.6.0.ebuild
@@ -8,81 +8,81 @@ DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} pypy3 )
CRATES="
- autocfg-1.1.0
- bitflags-1.3.2
- byteorder-1.4.3
- cfg-if-1.0.0
- convert_case-0.4.0
- cssparser-0.27.2
- cssparser-macros-0.6.0
- derive_more-0.99.17
- dtoa-0.4.8
- dtoa-short-0.3.3
- futf-0.1.5
- fxhash-0.2.1
- getrandom-0.1.16
- html5ever-0.25.1
- indoc-1.0.4
- instant-0.1.12
- itoa-0.4.8
- kuchiki-0.8.1
- lazy_static-1.4.0
- libc-0.2.121
- lock_api-0.4.6
- log-0.4.14
- mac-0.1.1
- markup5ever-0.10.1
- matches-0.1.9
- memoffset-0.8.0
- new_debug_unreachable-1.0.4
- nodrop-0.1.14
- once_cell-1.10.0
- parking_lot-0.11.2
- parking_lot_core-0.8.5
- phf-0.8.0
- phf_codegen-0.8.0
- phf_generator-0.8.0
- phf_macros-0.8.0
- phf_shared-0.10.0
- phf_shared-0.8.0
- ppv-lite86-0.2.16
- precomputed-hash-0.1.1
- proc-macro-hack-0.5.19
- proc-macro2-1.0.36
- pyo3-0.18.2
- pyo3-build-config-0.18.2
- pyo3-ffi-0.18.2
- pyo3-macros-0.18.2
- pyo3-macros-backend-0.18.2
- quote-1.0.16
- rand-0.7.3
- rand_chacha-0.2.2
- rand_core-0.5.1
- rand_hc-0.2.0
- rand_pcg-0.2.1
- redox_syscall-0.2.11
- rustc_version-0.4.0
- scopeguard-1.1.0
- selectors-0.22.0
- semver-1.0.6
- serde-1.0.136
- servo_arc-0.1.1
- siphasher-0.3.10
- smallvec-1.8.0
- stable_deref_trait-1.2.0
- string_cache-0.8.3
- string_cache_codegen-0.5.1
- syn-1.0.89
- target-lexicon-0.12.3
- tendril-0.4.3
- thin-slice-0.1.1
- unicode-xid-0.2.2
- unindent-0.1.8
- utf-8-0.7.6
- wasi-0.9.0+wasi-snapshot-preview1
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-x86_64-pc-windows-gnu-0.4.0
+ autocfg@1.1.0
+ bitflags@1.3.2
+ byteorder@1.4.3
+ cfg-if@1.0.0
+ convert_case@0.4.0
+ cssparser-macros@0.6.0
+ cssparser@0.27.2
+ derive_more@0.99.17
+ dtoa-short@0.3.3
+ dtoa@0.4.8
+ futf@0.1.5
+ fxhash@0.2.1
+ getrandom@0.1.16
+ html5ever@0.25.1
+ indoc@1.0.4
+ instant@0.1.12
+ itoa@0.4.8
+ kuchiki@0.8.1
+ lazy_static@1.4.0
+ libc@0.2.121
+ lock_api@0.4.6
+ log@0.4.14
+ mac@0.1.1
+ markup5ever@0.10.1
+ matches@0.1.9
+ memoffset@0.8.0
+ new_debug_unreachable@1.0.4
+ nodrop@0.1.14
+ once_cell@1.10.0
+ parking_lot@0.11.2
+ parking_lot_core@0.8.5
+ phf@0.8.0
+ phf_codegen@0.8.0
+ phf_generator@0.8.0
+ phf_macros@0.8.0
+ phf_shared@0.10.0
+ phf_shared@0.8.0
+ ppv-lite86@0.2.16
+ precomputed-hash@0.1.1
+ proc-macro-hack@0.5.19
+ proc-macro2@1.0.36
+ pyo3-build-config@0.18.2
+ pyo3-ffi@0.18.2
+ pyo3-macros-backend@0.18.2
+ pyo3-macros@0.18.2
+ pyo3@0.18.2
+ quote@1.0.16
+ rand@0.7.3
+ rand_chacha@0.2.2
+ rand_core@0.5.1
+ rand_hc@0.2.0
+ rand_pcg@0.2.1
+ redox_syscall@0.2.11
+ rustc_version@0.4.0
+ scopeguard@1.1.0
+ selectors@0.22.0
+ semver@1.0.6
+ serde@1.0.136
+ servo_arc@0.1.1
+ siphasher@0.3.10
+ smallvec@1.8.0
+ stable_deref_trait@1.2.0
+ string_cache@0.8.3
+ string_cache_codegen@0.5.1
+ syn@1.0.89
+ target-lexicon@0.12.3
+ tendril@0.4.3
+ thin-slice@0.1.1
+ unicode-xid@0.2.2
+ unindent@0.1.8
+ utf-8@0.7.6
+ wasi@0.9.0+wasi-snapshot-preview1
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ winapi@0.3.9
"
inherit distutils-r1 cargo
@@ -95,7 +95,7 @@ HOMEPAGE="
SRC_URI="
https://github.com/PyO3/setuptools-rust/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
- test? ( $(cargo_crate_uris ${CRATES}) )
+ test? ( ${CARGO_CRATE_URIS} )
"
# crates are used at test time only, update via pycargoebuild -L -i ...