summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-04 11:22:28 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-04 12:05:14 -0800
commit367de847556b354d5a462b90fc582c979760495d (patch)
treefff58f4ffc194c924726c7f204378954d828ffea /dev-python
parentdev-python/testpath-0.4.4: version bump, add py38 (diff)
downloadgentoo-367de847556b354d5a462b90fc582c979760495d.tar.gz
gentoo-367de847556b354d5a462b90fc582c979760495d.tar.bz2
gentoo-367de847556b354d5a462b90fc582c979760495d.zip
dev-python/jeepney-0.4.1: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jeepney/Manifest1
-rw-r--r--dev-python/jeepney/jeepney-0.4.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index dba5fd54f6bd..3959bb0f20bc 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1 +1,2 @@
DIST jeepney-0.3.1.tar.gz 22271 BLAKE2B a8de58e4ef4c4d1874c8995e3726a4bfa26a8db4a63040658c4edfd1742fa1c22de52d8cbee4913b1973279938544481fe2c2aef3138dc0ef724f7a99a39c617 SHA512 ad1a2d220a7626a3bdadf6fba6a591d1b498a9f6bb34607860213efddf49bbe67a4dc2d504decd906c560c519302f1fa45b85ba348156e8bec288f525d502e82
+DIST jeepney-0.4.1.tar.gz 27706 BLAKE2B 152bf872621a0e023b9f44bb165113b2c3ef0037f66cb1c2aa15423d68ae5c295ad100aba855f061840054a25c3ed30a2d1faed09cf2130235df72c70738c791 SHA512 46aed19fd29df724af0e78ec0acabeb196324444e682817c330f3fd290a52cf6a6cb639f8c76f4ef5311817c4e051d7231b4f26af3cb6768bdd8c4bec7589210
diff --git a/dev-python/jeepney/jeepney-0.4.1.ebuild b/dev-python/jeepney/jeepney-0.4.1.ebuild
new file mode 100644
index 000000000000..48c7b3cb6c42
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python 3.4 and older aren't supported
+PYTHON_COMPAT=( pypy3 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testpath[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}