summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-30 23:16:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-30 23:41:44 +0200
commit39a59ac14c710a23c3d20ab2b47492aa699cf602 (patch)
tree2283d99213815faf4d0cf3b17083433c5aa8816a /dev-python
parentdev-python/typing-extensions: Bump to 3.10.0.2 (diff)
downloadgentoo-39a59ac14c710a23c3d20ab2b47492aa699cf602.tar.gz
gentoo-39a59ac14c710a23c3d20ab2b47492aa699cf602.tar.bz2
gentoo-39a59ac14c710a23c3d20ab2b47492aa699cf602.zip
dev-python/hypothesis: Bump to 6.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.17.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f03a6a646d2a..b4754dff8ee9 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -6,3 +6,4 @@ DIST hypothesis-python-6.15.0.tar.gz 9138803 BLAKE2B 537d40d2f86b16730391e4f4f7f
DIST hypothesis-python-6.16.0.tar.gz 9140064 BLAKE2B 74d2963f71b357c1fcf5410271ef80a3f4f3540130c8e7ae5ec4408c07577962e30096d702a9feab25fa222cf23d85d865e816d661b8d5828570800b04453ef1 SHA512 92d98cb0a042d4abca9191ac46af6693ae2223433772622d33cd0838d2805fa72491421920af853ce258ec169037829ea1f924f35264d98319e2e0e3e7135f71
DIST hypothesis-python-6.17.0.tar.gz 9142908 BLAKE2B e366f5355e13471c211e91a54fc70e46e3c575d06352968ce4ec3f5cbae0c5442d07c5fefb0907664f262f3ddd1fc50f202d4e93deedea380221e9cba796f0b5 SHA512 320dddaa88a697e6b2fdd942fc08bce0cb1c49f4eeb0de39a7d404d98971d60b0edb332d9d2dd5f3a63b37301d458e361ebd995ccca6554e784e772a7cb3ed6f
DIST hypothesis-python-6.17.1.tar.gz 9143619 BLAKE2B c878313e062c37c8040efe7e659d39699690e066accd67fac1ae92abaff413eadf1a37e1c07ad7effc609ed5d0766274ef74272733088b5897fbad7eb25151a1 SHA512 6418f850b6642337d11bee7d78f82d061af1dd3a2e59dcda1e87ef88f99bda23ccbd6e6cb6cce00275380ddf125c77102bf88ae6a3884d754ef9f7cf9b68e4f5
+DIST hypothesis-python-6.17.3.tar.gz 9143941 BLAKE2B a23fd20fb46cb76f6ce57dccbfef182ddd57155e7cec0042ca593ce6176b9699901a5d7fc5092b321270420ac8ec729a7992b55674769216e9b81c53e3144db0 SHA512 c35dce24d3cb6de78e6f2699a67de3db165ecf5a26fa817f45c7b3af057b73a60a47299bbb66bacddb47eefdc0fc36457acab643bf7b256b79fa9387cab79427
diff --git a/dev-python/hypothesis/hypothesis-6.17.3.ebuild b/dev-python/hypothesis/hypothesis-6.17.3.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.17.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}