summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 17:27:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 17:42:31 +0200
commit460deb88a1d9df1b3bfd0ed9bc0a0d64119ceab9 (patch)
treede157f5b44d26709a8bab83d203df0760aeecc33 /dev-python
parentdev-python/pyperclip: Port to py39 (diff)
downloadgentoo-460deb88a1d9df1b3bfd0ed9bc0a0d64119ceab9.tar.gz
gentoo-460deb88a1d9df1b3bfd0ed9bc0a0d64119ceab9.tar.bz2
gentoo-460deb88a1d9df1b3bfd0ed9bc0a0d64119ceab9.zip
dev-python/cmd2: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cmd2/cmd2-0.10.1.ebuild2
-rw-r--r--dev-python/cmd2/cmd2-1.0.2.ebuild7
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/cmd2/cmd2-0.10.1.ebuild b/dev-python/cmd2/cmd2-0.10.1.ebuild
index c6dd48a3be49..e4ce45c0ea6b 100644
--- a/dev-python/cmd2/cmd2-0.10.1.ebuild
+++ b/dev-python/cmd2/cmd2-0.10.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
diff --git a/dev-python/cmd2/cmd2-1.0.2.ebuild b/dev-python/cmd2/cmd2-1.0.2.ebuild
index 52af0aec4425..0a10ae6eda41 100644
--- a/dev-python/cmd2/cmd2-1.0.2.ebuild
+++ b/dev-python/cmd2/cmd2-1.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
@@ -38,3 +38,8 @@ src_test() {
local -x COLUMNS=80
virtx distutils-r1_src_test
}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}