summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 10:13:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 10:33:32 +0200
commit4622e1e2ba77a3a79dc8e888cae997a61466db4a (patch)
treeeab08cc66a42d7f19298eb0b415dd83a806e8012 /dev-python
parentdev-python/jsonpickle: Remove old (diff)
downloadgentoo-4622e1e2ba77a3a79dc8e888cae997a61466db4a.tar.gz
gentoo-4622e1e2ba77a3a79dc8e888cae997a61466db4a.tar.bz2
gentoo-4622e1e2ba77a3a79dc8e888cae997a61466db4a.zip
dev-python/google-api-python-client: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.132.0.ebuild51
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.135.0.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 95d127a401f0..84f739a366f9 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,4 +1,2 @@
-DIST google-api-python-client-2.132.0.tar.gz 11256536 BLAKE2B 4a046c03a50b3922b94e6a07bfce974851752542a69300d544b7c8439c4ad54fc9fd2d5fdf84656801ebe9bf5ad35588d39dc3603537d67db93ea995b50651ff SHA512 ecd6be9009f979447ee7d29dc05af2b25c500ca17a8d88ae6660ac0a72f6bb8237f3224dda63b22378a38c6cf7fab914bc6372351d95e691c3b16f248be04a64
DIST google-api-python-client-2.134.0.tar.gz 11393129 BLAKE2B f5339dfa42f621dbdd145295a2c2710ef9e6e2af543ff5b9643bea884f9e0678065999d60cbf150a56e7b0d8c283588c53461c86eeb491a6ba2ad0c553a48344 SHA512 09a137ee3e3d8f38129fc02d8ffed8934daf6cfcd13904692f44038332da026b30d952048148c8c4fe5c4fed3347196574a860f58e1943312d19f6f03a01ab36
-DIST google-api-python-client-2.135.0.tar.gz 11420200 BLAKE2B abf9681b4aab9f001a790732d839e530894e531bca77a0cb0e850572c5a4d387ed4eb0134ede75dde5acfcf9944874c517c1624a7b7d56f65e9f43030282659b SHA512 9a4d344a0dc07e5570e35c85481e6ec2d7c5cd36608753e33b2be671562f3dc37462d1dd5ff850a883641a1d040960ac7929bd47e2678b1ce3691849eb181e6c
DIST google-api-python-client-2.136.0.tar.gz 11443821 BLAKE2B ee313274ec25e1262ad54b800cf524e58400886876d9133b7c6e1d9668e81bce7b73f96511679bcc2a0f565ca9b89c7d6bc7087213e53575542c5e0b5e566ff9 SHA512 e5e8302c71953f0971d3b3159d7689cd76520efa4cee9ca541e78a5fcb14387506963cb20da06ac5760af814ece5ded0bc3942381aa9e96fd6c620eb8933a6ed
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.132.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.132.0.ebuild
deleted file mode 100644
index eff0e425ea44..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.132.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="
- https://github.com/googleapis/google-api-python-client/
- https://pypi.org/project/google-api-python-client/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
- tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
- )
-
- epytest tests
-}
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.135.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.135.0.ebuild
deleted file mode 100644
index 224056fade87..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.135.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="
- https://github.com/googleapis/google-api-python-client/
- https://pypi.org/project/google-api-python-client/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
- tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
- )
-
- epytest tests
-}