summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-16 10:34:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-16 11:00:13 -0500
commit48986735d8a1517a4647033395783f4c5055b43e (patch)
tree46537569f7ee8307f335114adf72efad75aaabb2 /dev-python
parentdev-python/josepy: add py37 to 1.1.0 (diff)
downloadgentoo-48986735d8a1517a4647033395783f4c5055b43e.tar.gz
gentoo-48986735d8a1517a4647033395783f4c5055b43e.tar.bz2
gentoo-48986735d8a1517a4647033395783f4c5055b43e.zip
dev-python/pyrfc3339: 1.1 bump and py37 support
Bug: https://bugs.gentoo.org/685330 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyrfc3339/Manifest1
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-1.0.ebuild2
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-1.1.ebuild29
3 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/pyrfc3339/Manifest b/dev-python/pyrfc3339/Manifest
index 0c20db95adbb..553274a80ba5 100644
--- a/dev-python/pyrfc3339/Manifest
+++ b/dev-python/pyrfc3339/Manifest
@@ -1 +1,2 @@
DIST pyRFC3339-1.0.tar.gz 9325 BLAKE2B 4a02f2b128c34315def13500c2864d3198ba327fe3a39f04e14085d5dd945ffb31487c12d07e63e18c5946a14d8e380be8d85e7bea6b4df39f50550e6121379c SHA512 abcfcfcf516ab60214dc11de618d37415da2177387f51f85da99ef18b8cc0d37ed55f0ea6ba3e61292ce5a319838f322e01c1c9f3c0c4edb8341b4b135e575e3
+DIST pyRFC3339-1.1.tar.gz 5290 BLAKE2B d3094a22b6903937ae5cfee1210f04b65eb05dd606fe1d3245dca8ec0719ca1a079b720568d8c8e87fea691cebe1944098f99913b97a04570f06354a883e5694 SHA512 958b7761fab590aa42bb57a955c5d834441f717796a452b60df21663099dcf2fc046afe60f8157fd0f1edfd95c5e9c9c5349ab10ca4078d210fc63d848496a2f
diff --git a/dev-python/pyrfc3339/pyrfc3339-1.0.ebuild b/dev-python/pyrfc3339/pyrfc3339-1.0.ebuild
index 027f08e901b9..791994860ba3 100644
--- a/dev-python/pyrfc3339/pyrfc3339-1.0.ebuild
+++ b/dev-python/pyrfc3339/pyrfc3339-1.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
inherit distutils-r1
MY_PN=pyRFC3339
diff --git a/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
new file mode 100644
index 000000000000..0d30481718a6
--- /dev/null
+++ b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+inherit distutils-r1
+MY_PN=pyRFC3339
+
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Generates and parses RFC 3339 timestamps"
+HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests || die
+}