summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 13:27:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 14:13:32 +0200
commit4aefc96aa650e2e680512de1295192f00e5fbe9a (patch)
tree4ddd1610a9188c0e12178b0ea4e0ce0a5c55ad39 /dev-python
parentdev-python/ensurepip-setuptools: Bump to 67.7.1 (diff)
downloadgentoo-4aefc96aa650e2e680512de1295192f00e5fbe9a.tar.gz
gentoo-4aefc96aa650e2e680512de1295192f00e5fbe9a.tar.bz2
gentoo-4aefc96aa650e2e680512de1295192f00e5fbe9a.zip
dev-python/xarray: Bump to 2023.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.4.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 3f24823b5b47..a2071eed4401 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -2,3 +2,4 @@ DIST xarray-2023.2.0.tar.gz 3070514 BLAKE2B 00b08bb75878eed1aa82ac18ae5bc468d878
DIST xarray-2023.3.0.tar.gz 3686167 BLAKE2B b9c2e04d0278e383aef17280e74863244d458324c01ac59a453e72196d65cad8fbca9f8f99a33b6db66637f742e04e5615fa8fc6eed307f0511954a856f8f3d2 SHA512 c08269e6fc8cdd3123dd7c39e0b85959bafdc53a5da75187fc615281fb71212bf2e45059f8d18fa05339567a4827e7bb68de3e605416929a6a1defdb4ed393e3
DIST xarray-2023.4.0.tar.gz 3689883 BLAKE2B 50c5a18eaf28fc3bc38bc322dc393ec3e6a66c2651341019b389ba950c01f3950ee13e0922568f29ac1e3650ca9fdb55aec5574abe8f733959f15151208ac09b SHA512 1bb5052cb48e4ecb2d4e9d88cb0a0d3b25469b762d34059b5f65a88c2cbd125711d9af8a46a16b3eff3783f7d7653118b44503f19512ebc89845449a92efe1d9
DIST xarray-2023.4.1.tar.gz 3690082 BLAKE2B 33b8c8b6694911e0fb670dc60b784e9473a632bbdc793ac85685c9891933e373e40378c7362d7d3f7d6cf584716f8759ad73701d469534b70323d8e20d27ef3b SHA512 5bffb6b09d1188da27f19b6ec652ffb5a16ebdf036cf53f2d7c5b1805e7beababea6505127a23170d8ae8ad9453f429598b17f468c84b72ad07383ea3951d935
+DIST xarray-2023.4.2.tar.gz 3692437 BLAKE2B d4fb5b184386bb7e9574ea3bdf484c3df82b9dca1fcd2380ac65b6a58da9f89da057d70efa9bd045b5cf6900c38f6aa4176fd2990cfe1369f987c452711307d6 SHA512 581b06a677b80c0f7e494a80ae52d75bd62bf613b13b7b7215458ceef727fb55a898c8da8cc6f8a6875ef6898007897eea8be55fb138f1dacad42965bbf1d956
diff --git a/dev-python/xarray/xarray-2023.4.2.ebuild b/dev-python/xarray/xarray-2023.4.2.ebuild
new file mode 100644
index 000000000000..03b17a87a8c8
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+}