summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 00:14:07 +0000
committerSam James <sam@gentoo.org>2021-06-01 00:27:56 +0000
commit4f3daff22612673e8d1a5da1bb3b199fdd1c0340 (patch)
tree33a05eb1f37bdd8d849573e05323e127eb8b4e8c /dev-python
parentdev-python/requests-credssp: python 3.9 support (diff)
downloadgentoo-4f3daff22612673e8d1a5da1bb3b199fdd1c0340.tar.gz
gentoo-4f3daff22612673e8d1a5da1bb3b199fdd1c0340.tar.bz2
gentoo-4f3daff22612673e8d1a5da1bb3b199fdd1c0340.zip
dev-python/requests-credssp: lay groundwork for tests, drop unneeded patch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-credssp/Manifest2
-rw-r--r--dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch50
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.2.0.ebuild13
3 files changed, 7 insertions, 58 deletions
diff --git a/dev-python/requests-credssp/Manifest b/dev-python/requests-credssp/Manifest
index 38af56c1593a..ca9270fbf0a4 100644
--- a/dev-python/requests-credssp/Manifest
+++ b/dev-python/requests-credssp/Manifest
@@ -1 +1 @@
-DIST requests-credssp-1.2.0.tar.gz 18384 BLAKE2B 5d92326066f8e6abf675b3ab56522aceefb2ecf99bb58d44de4f0c40b46582b567888c6b888d21da29ef1746d070526c6d35601b88b5ca207f3c7f2b6c596260 SHA512 425e18b673cdf1006d6ab3d4108acdb2a8cdf6132646663741339c771aecada2cc237d919351cd0d2ca6022a0bcddba92b3b44b15386d683c6c18db461b8c7fd
+DIST requests-credssp-1.2.0.gh.tar.gz 23310 BLAKE2B 647dff76fbb47b9b972f403a9fb2a10ffab5e1915e32977e65b5f5c1cb206ec1b9fa884e12d687761087b2f7f4cb9e8bde631b68140cc50dbd9561a4999bdf55 SHA512 55458773cbf14a468d22d0b04186611385ff24fceda85052e69981bd6d4fd32a46f96b95fa36724b72fd9719485b2ed8906d1927284157e7bc685c0c42c2312c
diff --git a/dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch b/dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch
deleted file mode 100644
index 47591ab94edb..000000000000
--- a/dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From b3583f2e959600ea27a2b8577c172c5695ec7f2c Mon Sep 17 00:00:00 2001
-From: Matthew <matthewabtin@protonmail.com>
-Date: Mon, 10 May 2021 10:36:23 +0000
-Subject: [PATCH] Python 3.9 support (#22)
-
-* Python 3.9 support
-
-* Add 3.9 to pipelines
----
- azure-pipelines.yml | 8 ++++++++
- setup.py | 1 +
- 2 files changed, 9 insertions(+)
-
-diff --git a/azure-pipelines.yml b/azure-pipelines.yml
-index a60bd62..1f0cbde 100644
---- a/azure-pipelines.yml
-+++ b/azure-pipelines.yml
-@@ -38,6 +38,8 @@ stages:
- python.version: 3.7
- Python38:
- python.version: 3.8
-+ Python39:
-+ python.version: 3.9
-
- steps:
- - task: UsePythonVersion@0
-@@ -119,6 +121,12 @@ stages:
- Python38-x64:
- python.version: 3.8
- python.arch: x64
-+ Python39-x86:
-+ python.version: 3.9
-+ python.arch: x86
-+ Python39-x64:
-+ python.version: 3.9
-+ python.arch: x64
-
- steps:
- - task: UsePythonVersion@0
-diff --git a/setup.py b/setup.py
-index ee5268f..49af47b 100644
---- a/setup.py
-+++ b/setup.py
-@@ -53,5 +53,6 @@ def abs_path(rel_path):
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
-+ 'Programming Language :: Python :: 3.9',
- ],
- )
diff --git a/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild b/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
index a06c1ac3a655..4b4628b832ca 100644
--- a/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
+++ b/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
@@ -8,12 +8,14 @@ inherit distutils-r1
DESCRIPTION="HTTPS CredSSP authentication with the requests library"
HOMEPAGE="https://pypi.org/project/requests-credssp/"
-SRC_URI="mirror://pypi/r/requests-credssp/${P}.tar.gz"
+# .gh for tests in github tarball, drop ".gh" on next bump
+SRC_URI="https://github.com/jborean93/requests-credssp/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+# Needs unpackaged pyspnego (https://github.com/jborean93/pyspnego)
+RESTRICT="test"
RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/ntlm-auth[${PYTHON_USEDEP}]
@@ -21,9 +23,6 @@ RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}/${PN}-1.2.0-python-3.9.patch"
-)
+#distutils_enable_tests pytest